My WD My book 3.0 wont recognize drivers anymore

Hello all.

I ran into a strange issue i cannot fix.  My WD 3.0 worked fine for a good year and all of a sudden it started giving me problems.  I cant see it in windows anymore and when i plug it in and see it in device manager as WD Drive Management Devices, it states that no drivers are installed.  If i try to install the (downloaded) driver, it says that the driver is up to date already.  If i try to uninstall the driver, it hangs and times out.  I tried deleting all usb drivers on my computer and reinstalling them and that worked once or twice but no more.

Any ideas on how to fix this? 

Have you connect the drive into another computer? Do you encounter the same issue?

I have and I did indeed encounter the same issue.  Its not installing the driver properly.  Its weird.  Sometimes if i reboot my computer after messing around in device manager or what not, having the WD plugged in will stop the boot process and i get a black screen with a blinking cursor.  If i reboot again, it will do the same thing UNTIL i unplug the WD from the computer then it boots up fine.

Never seen this type of behavior in hardware and I work with computers for a living. 

I see people suggested I try a shorter USB cable.  I might go that route.

On the boot issue make sure that USB comes after your system HD. That can cause a hang on boot. Is this an addon card? If so check the maker’s site for updates. USB 3.0 seem a bit buggy. Also try updating all of the USB controller drivers.


The USB port drivers are up to date.  Note, this is being connected to a USB2 port.  I had an adapter for my laptop that didnt seem to work and never got around to getting it hooked up to USB3 so i left it as such until i get a new computer.

Any other ideas?  I cant believe this is happening to a lot of people.  It will be upsetting if my files are lost.  I’m sure i could have it recovered but i just want the drive to work…

Part of the problem is USB 3.0 was not a well done product release between computer and hardware makers. Drivers conflict with each other. You can try going into the Device Manager and start at the USB Host Controler and delete the driver and reinstall and work your way through the whole line to the external. I’ve seen this problems on other forums it’s not just a WD problem.


Yea I gotcha.  I’ve done that actually a bit back and while it worked at first, it just doesnt work at all now.  Funny thing is I got it to show up in Disk Management a couple times and it asks me to initialize it (never did from the start).  I tried that, but it fails, of course.

My next question would be, whats the best way to get the data off of the drive then?

Does it work with USB 2.0? If so maybe that will get your data off. You can also try burning a Linux Live CD boot from that and see if you can access your drive.


I’ve only used it as USB2.0 as my laptop only has those ports.  The Adapter that i bought didnt work so i just went with the 2.0 for now.  Thats what it doesnt work on, unfortunately.

It really bothers me that I have read a bunch of posts from other users having the same or similar issues and there is not a solution for this.  Obviously, WD has some issues going on here. 

Is there ANYTHING i can do?