My WD 1TB External Hard Disk ejecting automatically after every 5 seconds......:-(

Yesterday I have bought my new WD 1TB External Hard Disk USB 3.0 but after i unpack my HDD and started to attach to my laptop I was surpresed by the behaviour of my new brand HDD. It ejects automatically after every 5-6 seconds. Even I have tried on other computer, laptop etc. but the same problem arises. When I attach my USB modem, Pendrive etc. to my same laptop nothing happens. It works smoothly and even properly but when I try to attach my HDD the problem arises. Please if there is any solution discuss with me. I’m fed up of the problem.

Thanks in advance…


Did you tried using another USB cable or connecting the power cable to another power socket?

Does your laptop have a usb 3.0 port, or was this on a usb 2.0 port?  Also, I would consider, if you can take the drive back and replace it with another, to try another drive and see if it happens again.  This way we can eliminate it being a bad drive.