My WD 0730 My passport has gone unstable


I have been using my WD (WDBACX00…USB3) for one year without any problem.

Now suddenly, it became unstable.

It was used on many different hardware like a popcorn A300, a Windows 7 pc, a Mac book.

Now it runs nicely on everything but not Windows any more. I have even tried on another pc with windows 7 or  windows xp sp2, still no success.

If I plug it on a mac, it works also like a charm, also the popcorn.

When plugged in a Windows pc, the windows explorer shows it as “Local disk” but when clicking on it, it hangs the windows explorer.

This disk has always been ejected the nice way. Never rip off the cable, always dismounting it.

 What happend?

I have installed the latest firmware in case, but it is not better.

It was formatted to be used on pc and mac on ntfs (read only on mac).

Thanks for any help.



If you connect the drive in the Mac computer and the media player and the unit is working fine, then you are dealing with a computer issue, have you try connecting the drive in another Windows computer?

Tanks for the reply.
As I wrote, I have tested on two differents computer without any success.
There must have been an USB issue somewhere.
But I managed to copy the data on another disk with my Popcorn. And now my disk has been formatted and working.