My turn ...!

Hey everyone,

I bought 2 of these NAS boxes (white ring) about 2 weeks ago. I switched from 3 DNS-323 from D-link because of their lousy support and updates for Lion and HDD > 2 TB!!!

I am not sorry for my decision. So far, I’ve survived! But, here’s my 2cent:

First, it took less an hour to get the impression that the firmware / software for WD boxes are being developed by  a few co-op students! Heck, I can’t even make a share with space in it! Why the heck not?!!!

Anyways …

Those who have issues with Time Machine and or any other connectivity issues, get rid of Twonky and NOW!

I’ve had nothing but trouble until I killed this piece of junk!

That’s all. Instruction to disable Twonky has been mentioned many times. Do a search and you’ll find it.

Good Luck.

How confident are you that this will fix the connection issue?  (I realize you are no way responsible if something else goes wrong, just like to know a confident level before I go this route.

So confident that I deleted “S97twonkyserver” once and for all … OR, until the next firmware upgrade which is going to put it back.

The latest firmware screwed up Bonjour which also affected both my NAS boxes, my wireless printer even my external USB HDD connected to Apple Extreme! I had to power cycle everything and restart until 1/2hr.

24 hrs+ and counting no problem.

What do you have to lose? You can always move it back or do a manual firmware upgrade.

SSH’s language isn’t my forte.  Mind walking me through it?


 n/m.  found a writeup.  I did this exact same thing earlier today though and it didn’t fix my connection problem.

Just like the first time I tried this, after running chmod 644 /etc/init.d/S97twonkyserver through SSH though the drive would not reconnect on its own.  I got the drive reconnected, but last time at this point it looked ok but the connection eventually failed within an hour.

Any suggestions of what I might be doing wrong here?

Use this command instead of chmod. That never worked for me.

mv /etc/init.d/S97twonkyserver /root

It’s gonna move the file to the /root folder.

If any issue, you can always move it back to its default location:

mv /root/S97twonkyserver /etc/init.d

OR … you can also download the latest firmware and manually update your box.

hmmm.   got an error

mv: unable to rename `/etc/init.d/S97twonkyserver’: No such file or directory

i undid the changes i made, even went into the media server and rescanned and restarted and still got the above error.  I think I just go back to the chmod command i did and see how that works out.  If I sill have issues I’ll try the 1.02.06 firmware again that you found.

Thanks for he help!