My safepoint on WD My Cloud keeps disappearing

OK…I have a WD My Cloud (with latest firmware) with a WD My Book connected to it via USB. I have set up the WD My Book as the safepoint location and also (on several occassions) set up auto update. However, every time I enter the dashboard (a day or so after set up), it says that no safepoints are found! I again se up a new safepoint and the problem repeats itself.

I have checked the content of the WD My Book and each afepoint that I had created are there. Why does dashboard not see any of them or auto back up?

The most annoying thing is that I have the same problem in my office, where I also set up a WD My Cloud. There I have a Lacie Drive connected via USB for back up. Again, the same problem!


Have a look at my post below which is headed 'Happy accident…", it gives you a faster, more reliable alternative backup to


Here’s the thread:

Thanks for your advice. But as you say yourself, it’s for people that actually know computer language. I am a mere end user. More so, it’s just plain absurd that after paying so much money, I then need to get tech education to use the, after all, hard drive storage device!

Today in the office, everyone was (again) complaining that they could not access the WDMC. I could not even access the dashboard! We had to reboot it (again).

Is this the quality that WD considers appropriate??

 Is this the quality that WD considers appropriate??

Possibly… Have you tried asking them?  Remember, we’re not WD Support; this is a user forum, and we’re customers, just like you…

A ‘SafePoint’ that doesn’t work reliably isn’t very safe, I agree. I don’t use it or any of the WD apps…

ps. Whilst I agree that a device marketed as a ‘Simple 1-2-3 Setup’ really ought not to need Linux admin skills to get working properly, it is more of a home appliance, and use in an office might be better served (excuse pun) by a more ‘professional’ device. And an office network really ought to have someone who does have some understanding of computer system administration, either on the staff, or under a support contract.

I have the same issue. I have my device a couple of months and I have it set to automatically back up to my Safe Point every night at midnight. It worked for a few weeks and then I noticed it had stopped - on checking through the dashboard I was told no safe point found. Trying to create a new Safe Point wouldn;t work as I was told it already existed. So I wiped the external connected hard drive and started from scrath again. Worked again for a few weeks and stopped again late last week. The last firmware upgrade was supposed to fix safepoint “stability issues”.

If you can’t rely on a device like this it’s rubbish. I have a buddy who recommended I set up a Synology based cloud system and back up and I didn;t take his advice. Regretting it now.


And I have the same issue too. I disconnected temporarly the USB My Book from the My Cloud device, and 2 days later now, when I connected it back, there’s apparently nothing that will make it find the 2.5 TB safepoint to update it. Although the Safepoint itself stays safe and sound on the My Book and it can be accessed as a recovery option throug the same Safepoint menu on the MyCloud. Just incredible!