My Router is the master browser? How do I fix this

Hi guys, sorry, this isn’t really about the WD TV Live, but I can not seem to find the answer anywhere.

I have a small pier to Pier nework.  Router, a couple of computers (Win7 Ultimate has the shares and is on all the time), and WD Live.

My Windows 7 computer did an update, and lost master browser status on restart.

I need to somehow default the Windows 7 as master browser as my router doesnt have the brains to do this properly.


Put the router in its own workgroup.  Call it the “Naughty Seat.”

ok, here is what I did…

  1. set static ip to the Win7 computer and unplugged it from the network

nbtstat -a just returned an error.  Not going to work for me.

  1. -plug in a laptop (W static ip) and Win7 computer in to a switch (Felt I had to since the router kept becoming master browser on me I had to get the Win7 computer off that router)

  2. With the router unplugged from the switch, I ended up with the laptop as master browser.  Close but no cigar.

  3. Unplug the laptop from the switch.

Now nbtstat -a still worked,  I kept refreshing until I saw the Win7 box was master browser…Yipeee.  Sucess

  1. Plug everything back in, keeping a couple of static ips (Outside of DHCP range, of course).  Now I can check network neighbourhood with the XP laptop and it works (Couldn’t before).  Test WD TV Live…It works also.

Other things I noticed…1. I have a Win7 Laptop that was still able to browse my network shares with Master browser on the router.  This seems to indicate that XP and the wdlive share the same coding for browsing.  I think Microsoft is making xp’s method of browsing a network obsolete (Also WD TV Live’s method, and probably linux).

Sooo…is the fix to use a home server?  I’m still not sure how to make sure the proper machine stays as master browser.

Can anyone help me here?  Maybe some of my observations are not quite true?  All information appreciated.


Thanks Tony!!!

I didn’t see your response.  What an easy solution!!!



My Router is also set to master browser and I think it may be the cause of some of my troubles.

Sorry for a stupid question, but how do I put the router in another workgroup? I have XP Pro.

Also will this solve this issue:

I lose my network share after the unit hasn’t been used for a while (like in the morning when I try to use it). Most of the time I can reboot the hub and it will refind it, but sometimes I will have to reboot my entire network (router, modem, pc). and then it will find it. The router share (Readyshare) is always present on the hub, so i am thinking that because it is master, that is my problem. Would this be correct?

Another issue I am having is I installed a new HD and moved my entire share from C:wdtv to H:wdtv. After the move I deleted the C:wdtv and the hub would not find the new share. I had to remake the c:wdtv and set it to share and presto it would show the share on my h drive. Now there is nothing in the c:wdtv, but if I delete it I lose my h: share on the hub. Could this also be because the router is the master or is this another problem all together?

Thanks for all the work you do to help people like me to keep thier hub going!


You’ll need to consult the documentation for your router to determine how to do that.  

If you’re changing your shares around, you may need to do a full reboot on the Hub to get it to detect the change and re-index everything. 

The router probably isn’t the cause of the last problem, but could be part of the other problem…