My Personal Cloud not visible after moving to new network

I moved to new city and reconnected my personal cloud to my new network. I’m unable to access it. The blue led was steady, but nothing. Then I disconned and reconnected and the HD leds are blinking like crazy, the top blue led is steady, but still the cloud is not detected in my network. Please help to troubleshoot and fix.

Hi, welcome to the community.

If you moved the drive to a new location, most likely is trying to get the previous IP and is not getting the connection.

Try resetting the drive, by pressing the reset button in the back and then see if the drive shows on the network.

A few additional questions, just to clarify a couple of points:

  • Is your MCM set up with a static IP address or a dynamic (DHCP) one?
  • How are you trying to see/access the drive?
  • If you type \ in Windows Explorer, does it show up (replace with the name you’ve given your device, by default it’s \WDMyCloudMirror).
  • Are you connecting to the same network (same router/DHCP server) or a different one?

I will go by memory now, until I can get back to my home network.

Setup with Dynamic IP

I was trying to access from a windows 7 computer connected to the same router.

From the Windows Control Panel, Network and Sharing Center, it was not visible in the full map

Disconnected and reconnected the network cable from the router, and was able to notice that my personal cloud LED changed to orange, and upon reconnecting it blinked until it became stady blue again, but still invisible in the network.

Since I have also a new laptop where I had not installed the WD tools. I reinstalled and was attempting to setup my cloud as if it were the first time, but it was not visible.

I’ll try once I’m back to my home network.

One more question, if you go to your router’s dashboard, does the MCM appear in the client list (the list of machines connected to it that it has assigned an IP address to via DHCP).?

Now that the forum is back. I can say that my WDMyCouldMirror is just not visible in my network. I connected it to my router and/ or to a network switch, all blue LEDs are steady, but it can’t be seen in my network. I have a fiber optic router and a NETGEAR ProSAFE Plus Switch, but it doesn’t matter where I connect the network cable to My Could Mirror, it just can’t be seen. The back green LED behind My cloud for the Ethernet port blinks as well as on my switch as if there were network traffic but it’s invisible.
When I use WD My Cloud it shows the cloud as my previously connected devices, but when I try to connect it shows and Error message: Can’t connect to this device, Failed to connect to the device (I assume it tried my old network.
When I click Search for devices in my network, it replies with No Devices found.
What can I do next?, I don’t know what to do next.

By the way, I don’t see a reset button to try to reset as someone suggested. I see a pinhole with a ( ) symbol, that I tried to use as if the reset is inside that, but I didn’t notice any change.