My Passport, works; not regonized

1TB My Passsport. When plugged in via USB, I can hear the drive spin and the light flashes. If I prop it up and play with it for awhile, I can get the drive letter to show for a brief second in My Computer.

I’ve come to the conclussion that the USB hook-up on the drive is shot. So I’m wondering how I can get the data off the drive without sending it in to an expensive data recovering service.

At this point, I’d rather void my warranty than pay for data recovery. The fact that WD offers full replacement without data recovery kind of ticks me off.

Well dude that depends on which Passport is the one you have. Some of them have a native USB port and don’t have a SATA port inside the casing, and some of them are hadware-encrypted and will be encrypted after taking the case out even if you never created a password. You’ll have to test and see.

Then again, if it’s a USB 3.0 then did you try a 2.0 cable? I have seen the 3.0 drive failing and the drive still works on USB 2.0 cables. It’s not proprietary. it’s a custom Micro 2.0.

I have encountered that same issue when i accidentally drop my 1TB Wd passport (table height but it is inside my bag). When I plug it in the usb it will light up and make some sort of noise it will show up that there is a passport drive connected but it cannot generate a drive letter. Don’t know what to do and I want to recover my files can some help me? Thank you in advance.

It might also be a bad cable try another one if possible. If you get it recognized don’t move the drive and transfer the data off right away.


I have tried several cables still no luck, everytime I attach my 1TB on my computer it’s making some weird sound.

Then it’s most likely the USB port on the card that’s bad. If it’s a drive that came with Smartware it is hardware encrypted and you can’t simply connect as an internal or use a third party enclosure. You might try having a new USP port soleded on to your card or find a replacement board. This explains a bit and then this Remember opening the drive voids the warranty.


I’ve tried several different cords. All USB 3.0. I don’t have a 2.0 that would fit the slot.

I formated the drive when I got it so there’s no smartware on it.

But yeah. Soledering a new board is way out of my league. I think I’m just at a lost here which bums me out. Had it been a normal drive with SATA hook-ups; I’d be fine. But noooooo.