My passport wireless ssd streaming really slow and buffering every couple of seconds on a small video


#1

Hi,

I have recently purchased a 2TB My passport wireless SSD and was really excited about the prospect of streaming movies etc from it. I have imported the contents of a 64GB SSD (Approx 30GB) and it was fast enough to do this.

The problem I am experiencing is the extremely slow speeds when streaming, I have tried connecting from an iPhone 10, ipad and laptop.

Any ideas please, I have read various reviews, one of them from a guy saying that he runs it where up to 4 people can stream films from it, I am lucky to be able to see the photos and have given up trying to stream a 1080p .MOV file (67MBs) as although it starts playing it is buffering every couple of seconds.

Is this normal, I only received the hard drive a couple of weeks ago so am thinking of returning it to WD for a refund, I have restored to factory settings on the system and disk and reloaded the SD card with no change in speed, unfortunately this has meant I have lost any factory installed software that was previously on there so don’t know where to re-download everything.

Really frustrated considering the money the item cost.


#2

First of all, an owner of the MPWSSD needs to have a copy of the complete user manual, which was on the drive, but if you cannot find it you need to download it from WD support and store the pdf on your computer so you can refer to it OFF the SSD drive.

That done, it is best to first connect to the unit’s internal wi-fi; I suggest the 5G signal. If you have it concurrently connected to the internet/home network as per the setup instructions, that’s fine, too, and recommended for home use. In this case you connect your iOS device to the home network’s wi-fi (recommended for home use) and place the MPW near your router, not near you and the mobile device.You sit where you have a very strong home 5G wi-fi signal, too. Video streaming needs very good 5G wi-fi. Using the slower 2,4G is NOT recommenced for video use. I never keep my iOS devices connected to anything other than 5G

Regarding your restoring to factory defaults, hopefully you followed your manual’s instructions and selected to RESTORE (or reset) System Only and NOT the whole thing including all data. This insures you DO NOT delete any of the pre-installed software, folders and files, nor your own data.
So, connect the MPW to your computer’s USB port (when MPW unit is turned off) and look at the contents to see it it all looks intact. Hope for your sake, it is.

If instead, you formatted the MPW, well, that was a terrible thing to do because the drive WAS whipped clean. I never have needed to re-format any of my wireless drives (and I have quite a few). Do not do this to yours either.

Regarding the MOV files you are having a problem with. Confirm for me they are from an iPhone/iPad, and you are trying to play them with the My Cloud mobile app. If so, I have the same issue with my MPWSSD. ANY other movies I play from drive that are mp4/m4v files (movies made via Handbrake) work perfectly; just not the iOS movies.

I have reported this problem to WD, but so far they have chosen not to improve the situation.

Also, nave you explored the Dashboard for the MPW? It can show you things such as if the MPW is connected or not connected to the home network. The dashboard can easily be accessed from Safari browser on iPad.


#3

Hi Mike27oct,

Thanks for your reply, I have done as you suggest and downloaded the manual and stored it on the drive.

I have set it up to use the unit’s internal wifi using the 5g signal, this is then routed to a 5g SSID from my virgin broadband, to be fair this part of it is working ok’ish, if I connect to my virgin media router directly from a laptop I am downloading at 160mbits second, if I connect through the WD unit I am getting 12Mbits second which is considerably worse, but at least it works, hopefully WD will be able to do something to improve this side of things in the future.
Unfortunately I did restore to factory defaults which wiped the whole hard drive (system and disk), it got to a point where I just wanted to get it working whatever the cost, when you view the drive contents there is nothing at all shown, but it still appears to be working as before, I’m assuming the software to run the device is stored on a separate partition, for example it sends out a wifi signal which can be connected to and can be connected to remotely either via MyCloud on a tablet/ iphone or via a browser on the computer.
I think I have a theory of what the problem with streaming is, when I uploaded the contents of the SD card which contains photos taken from my Olympus camera, it contains approximately 3 thousand images and a quite a few .Mov video files, it feels that if you want to view the files over the internal wifi you have to wait for ages before they are worked through by the unit and have had thumbnails created, if you try to view them before this has been done it is extremely slow and videos are pretty much not worth looking at.
It doesn’t bode well for when I am away taking photos and uploading them via the SD slot, I expected to be able to upload images/ videos and work on them straight away, at the moment it feels like I could use most of the battery power up for the unit to do it’s configurations before I can view them successfully and quickly.
To be fair, eventually they stream well (After a few hours), I have also uploaded some films which are streaming very quickly, which is why things seem to be pointing to creation of thumbnails or something to do with the database, maybe indexing?

Regarding the .Mov files, they were created by the camera.

Thanks for your help,


#4

OK, I have helped you all I can, so if you want to recover any of the important pre-installed data , contact WD Support by phone and see how they can help you out. Wishing you better luck wi your new drive.