My Passport Wireless Pro - System Recovery or Hard Drive replacement


Have you tried using the files app and usb connection between the phone and disk?


It was via the terminal. I was connected via uart/serial and noticed errors about partitions not existing while the firmware was installing. Since I know that that firmware should partition the drive properly, I decided to use ‘fdisk -l’ once it booted from the new drive.


I have, same thing happens, besides I don’t want to download to the ipad first and then import into Lightroom CC. Also, Lightroom CC pulls up a Files app proxy menu when it imports the files anyways, so I don’t think it changes much.


I use linux daily and have no problem in updating it manually, but as I understand it the NAS-bug will still be there rendering it useless if not used in usb-mode?


While I don’t know 100% yet but I think the root cause is that the partitions are not the sizes the firmware is expecting. My reasoning behind this is because I was able to manually create the partitions on my Linux box on a HDD and boot from it fine. Granted it was an older firmware but I doubt it’s changed.

Keeping this high level to hopefully discourage folks that aren’t familiar from attempting to do it…
Connect the drive to your PC outside of the MPWP, like a standard sata to usb adapter. Format the drive with MBR partition and all partitions primary. First partition is the total size of the disk minus 4G for the hidden partitions. Second and Third partitions are 1G each. The Fourth partition is the remaining 2G. Once you write those changes to the disk, pretend like the second, third, & fourth partitions are a drive themselves (ex: fdisk /dev/sdX2) and make partitions within the partition. For the two 1G partitions, the first should be +512M with the remaining space going to the second partition. For the 2G partition, the first partition should be +1G with the remaining space going to the 2nd partition. Once you’ve completed these steps, use ‘losetup’ to get access to the partitions within the partitions. From there, you can pretend sdX2 is /dev/sdb, sdX3 is /dev/sdc, and sdX4 is /dev/sdd on the MPWP. Format them accordingly, copy of the files, and extract the rootfs.tar.gz to the two sdX4 partitions.

sda1 - exfat - this is where your data goes and that’s accessible via the MPWP usb connection
sdb1 - ext4 - a backup firmware image/file. My MPWP has MyPassportWirelessGen2_1.01.07.bin while the SSD version had a newer version. I believe it doesn’t matter what version is on here so put the newest.
sdb2 - ext4 - is use as a log partition of sorts. All you need to do is format it and the OS will take care of the rest.
sdc1 - fat - holds the bootloader/kernel stuff. The official update script uses this location before it flashes it to the ROM/storage on the board.
sdc2 - swap - swap partition…
sdd1 - ext4 - the os root filesystem.
sdd2 - ext4 - the os root filesystem.


Just curious, if you rate the photos, how would it sync with the desktop editing software? Or do you intend to keep the photos in the drive for awhile and use the rating locally?


The Lightroom CC apps (Mac, Windows, iOS, and Android) all sync to the cloud. Any rating and edits/adjustments made on the iPad Pro would sync to the Mac. I can then filter out the photos that were rated to be edited and rate those in CaptureOne or Lightroom Classic CC manually. Technically Lightroom CC can be synced to Lightroom Classic CC, but I haven’t had the time to figure out how to sync a Lightroom CC JPG folder back to a Lightroom Classic CC RAW folder. In any case, gnarbox 2.0 seems to allow rating to be written to EXIF which could be a better solution for my purposes.


No progress on this? @PuDLeZ


I think I’ve fixed the issue with replacing the hard drive with a X600 but been too busy beekeeping to fully wipe the drive and give it a test.


I would love to see if there is any speed improvement for SD card import speed with SSD replacement,

just bought a 4TB version and use for 4k video backup,
which is just tolerable with 30MB/s for old spinning rust.


I can’t speak from personal experience (yet) as I’ve had a 4tb model on back-order for weeks.
Unfortunately they have been largely out of stock at the large retailers (Amazon, Best Buy, B&H, Adorama) for up to a month and are just now coming back in stock. Makes you wonder if there was a supply chain/manufacturing issue and/or any electronics changes.

However, after reading a number of reviews going all the way back to the 2TB model, I get the impression the SD card reader in the wireless pro models are capable of backing up data from SD card to internal HDD at close to the advertised ~60MB/sec SD read spec. Of course this will be dependent on the read speed of your particular SD card(s) and would only apply to the best case scenario of sequential reads of large files. (Video, large raw files, etc.) Also this is more of a limitation of the SD Card reader and SOC than the write characteristics of the HDD. Reviews show PC to HDD seq. writes via USB3 are closer to 100MB/sec… so the bottle neck is NOT the HDD at least for sequential xfers. And while random write perf for SSDs tend to be much better than HDDs, the random reads even for higher end SD cards still tend to be only ~5 - 12 MB/sec and will be the majority of the bottle neck as writes to HDD will be buffered in the HDD electronics and/or likely even cached by the SOC for write perf reasons.

As for SD backup in the SSD model - Reviews I’ve seen don’t show SD card backup to be much if any faster. Also PuDLeZ has mentioned the electronics (ARM SOC, SD card reader, etc) are pretty much the same between the wireless pro and his SSD review unit. To back this up, pics of the PCBs and component layout in tear downs of production units look pretty much the same to the naked eye. Now WD does list the SD read perf on the SSD model as up to 65MB/sec, but the real world difference is likely less than ~5% for most use cases.


I can’t find any review indicate pro model can do 60MB/s, only SSD version can do that number, many review doesn’t give the number about the backup speed, mostly just repeat the marketing words about 60MB/s

I did a simple test by ssh into the Pro model,

the reader it self can do 60MB/s, the Hard Drive alone can do 80MB/s

but if you simply test the sequential dd command test from SD reader to Hard Drive, it never get over 40MB/s, which shows there is bottleneck somewhere, that’s why I wonder.

and by the way I do send support ticket to question about this to WD, and their support desk only sent me WiFi connection speed FAQ which is complete unrelated, then they just tell me to send my unit back for RMA,

they literally don’t care about this model.

that’s turn me to some China made mobile backup device,

device only for $370 USD
which can do CFast/XQD/SD,
replaceable 2.5" drive,
powered by 2 18650 battery,
have a basic graphical display
have wifi this is not really useful as you can’t expect much for app support as it’s a dedicated device,

but it do darn fast copy speed up to 140MB/s and you can operate without your phone or computer.


After going back through several reviews that test SD copy performance of the pro units, I’ll say the numbers do vary between reviewers.

Here’s where I get my theoretical numbers:

Claim of 20.14GB (546 files) in 5:40. 20140/340 => ~59.24MB/s

Claim of 1.51GB (57 raw files) in 28 seconds. ~58MB/s (average of 3 tests but 1.51gb is too small a data set to be a reliable gauge for my use case.)

Claims 50MB/s.

The lowest I’ve seen in a review is ~38MB/sec… but it was one of the better reviews and used a 95MB/s read SD card.

When my units comes I plan to run benchmarks with both the HDD and SDcard(s) formatted with different file systems to see if that makes a difference. Also I’ll be using the built in backup/copy function. There could be beneficial caching that occurs with the OS’s file copy APIs that you aren’t capturing with DD alone.

Agreed, nice specs on the PD800. Personally I should be ok with the 4TB WD Pro on sale for ~142 US. Even at ~38MB/s a full 128GB card should take less then an hour for complete backup… incremental backup will take far less. Swap cards when I’m at the hotel, press the copy button, and walk away.

Update: 2/12/19
Stumbled across this old thread and noticed I forgot to post the results of my perf tests…

Summary: SDCard to MPWP backup is significantly faster if the MPWP is formated exFat instead of NTFS. But keep in mind that NTFS is considered a more resilient file system. (journaling)

SDCard (exFat) to MPWP 4TB HDD (NTFS) >> ~30.2 to 30.9 MB/s. (6 passes. Reformat between each.)
SDCard (exFat) to MPWP 4TB HDD (exFat) >> ~42.3~ to 45.6 MB/s. (6 passes. Reformat between each.)

Test conditions:
My Passport Wireless Pro 4.0TB. v1.04.17 firmware released 1/8/2018 (latest/last :frowning: ).

Reformatted NTFS and exFat between each xfer test via Win10 build 1803.

WPWP “reboot” via webinterface > Admin after each reformat.

Test Data:
28.5GB mix of 410 files. (jpgs + raw, movs) copied from 128Gb SanDisk UHS-II. (UHS-I mode.)
27.1GB mix of 400 files. (jpgs + raw, movs) copied from 256Gb SanDisk UHS-I.

Both cards formatted exFat in camera (Sony) as that’s what my camera(s) support.

MPWP 4TB formatted NTFS (4096 sector size. Confirmed 4k sector aligned. Formatted once with larger sector size after seeing the exFat results, but decided not to proceed with the test as the web portal did not properly calculate the drive size. ~700mb vs 4.0 TB…)

MPWP 4TB formatted exFat (1024KB sector size Yes, KB… that was the default in Win10.)

File copies started by pressing the file copy button. (Auto copy on insert disabled.)


my unit tested with
SanDisk Extreme Pro SDXC UHS-I(V30) 256G
Transcend TS256GSDC300S
both support UHS-I and up to 95MB/s read,

test file is 4k video shot, so no random read/write for small file,

both failed to get over 35MB/s when import to drive,
direct dd dump card reader into null or dump zero/random into harddrive is way over this number,
it just capped there for some weird reason,

dd do ignore the cache, but same speed issue also shown by using cp,
from digging into the import script of WD use for import file,
they just use cp,
rsync is a no go due to the performance of the unit is too low for it’s cpu to catch up,

and the incremental backup is a mess done by rsync dry-run,
if you look into the script that will drive you crazy, tons of room for improvement,

this unit won’t get much benefit from cache due to it got bare minimal of memory to operate,
and cache only help on repeat usage pattern, which doesn’t happen when import,

and the tricky filesystem overlay over the harddrive mount with “pmxcache” module,
format it with different format is a no go unless you want to start working with that part,

in my personal experience about MPWP is, you get what you paid for,
the outdated software and web interface,
unreliable operation by four LED light to indicate the copy operation, which won’t warn you about any failure,
no longer updated software,

i’d pay more to get something that works reliable.

EDIT: forget to mention I bought 4TB model


Hi, i try to repair my MPWP - 3 months I did not use the disc, but when turned on, it first flashes wi-fi and then all led flashes. I tried to do the reset and flash with SD but did not work. I took out the HDD and connected it to the computer - I saw an empty partition 4gb at the end of the disk.
Tell me after I created the partitions inside the partitons in fdisk what commands do I need to connect them through losetup?
Also i have USB to UART and can connect to mb - this can help me restore firmware?


anybody can help me?


Did you get a chance to test it?


yes i try to create all partitions, but can’t boot, maybe you can copy boot partitions and upload for me?


Hello together,
how is the status with the System Recovery or Restore?
is there a chat group or mailing list, or anything similar?
Have a WD MyPassport Wireless Pro SSD open and serial terminal available, also spare drives and untouched stock drive.
Feel free to hit me up.

regards Dominic


Hello guys!

I bought the 2TB version. Inside is a WD20SPZX. My plan was to replace it with a 5TB hdd from Seagate ( ST5000LM000). Following the steps above, I copied the latest firmware on an SD card and tried to do an update.

Powering up, the HDD-led is lit and WiFi ist blinking. After about 30sec. all 6 LEDs start flashing rapidly.
It doesn’t make any difference if I press both buttons at startup for 10sec. or not.

If connected to USB, the computer doesn’t recognice the disc.

Any advice on how to proceed?
Or was my experiment a waste of money? :frowning:

Thanks in advance!