My Passport USB 3.0 NOT working


#1

My pc has 2 USB 3.0 ports. Under device manager, both USB 3.0 Host Controller and Root Hub are installed properly. When I plug my passport to the SUB 3.0 port, it didn’t work. System shows it is still using the USB 2.0 driver. I tried to reinstall a USB 3.0 driver to the device and it still didn’t work.

The device works in the USB 2.0 ports.

Any ideas?

Thanks 


#2

Hi there, have you tried another cable?


#3

Since the cable works when connecting to USB 2 ports, I don’t think the cable is the problem.


#4

Figured it all out.  I have 3 of the passport Essential 1TB drives and have been using 2 of them now for about a month.  I got a new laptop with the new USB 3 option.  Cool!  Faster!  NO!! Plugged in and wont recognize drive.  I know computers.  Tried everything and went crazy.  Got one drive to recognize but if I touched the cable it would drop.  Hmmm… Maybe cable… no, works on USB 2… Well finally broke down and opened my NEW Passport Essential and plugged in the new cable and WALA!  No more problems.  All three drives come up fine using this one cable.  The other two cables have been used in USB 2 ports on my workstation and somehow being plugged into those ports has damaged them internally.  After more testing of my two bad cables I was able to get one of them to work if I held it just right.  If I touched it boom… Connection gone.  Both still work fine in USB 2 ports on any computer but as USB 3 cables they are NO GOOD.  I chalk it up to crappy cables from WD.  So, I hope this helped.  Rarely do I have a cable issue but this is one of those times.  Best of luck!