My Passport Ultra recognized by one computer, not on two others

I have a comparatively new My Passport Ultra.  It seems to work well with my Sony Vaio laptop, but when I tried to use it on some other computers, no go.  ??!!

Using the original short cable, on:
  Dell Studio XPS laptop, Win7 Home Premium SP1, USB 2.0
  Desktop, Intel i7, Win7Pro SP1, USB 2.0 and 3.0

WD Smartware says:
  Flyover text:
    Product Name: My Passport Ultra
    Serial Number: [Deleted]
    Product ID: 0820
    Firmware Revision: 1007
  The box that shows capacity and usage:
    “No writable partition found”

WinExplorer / My Computer: not recognized

Smartware, “Safely Remove Hardware…” and WD Quickview all allow me to remove

Computer Management / Disk Management: doesn’t show

Device Manager:
  No USB problems
  WD Drive Management devices / WD SES Device:
    This device is working properly
    Driver up to date

Both of these computers have the latest WD SES drivers and WD Smartware.

Could it be that the WD SES drivers aren’t appropriate?  Any help getting the Ultra to connect to these two computers gratefully requested.  Thanks.  --Howard


Make sure that you are connecting the drive on the back USB ports of the desktop computer.

Also check again on the Disk management to see if there’s any unknown disk.

((Sorry for the delay in replying–I wanted to make sure that it worked on both computers, and I didn’t have access to one of them until a couple of days ago.) This is really strange: I had previously tried plugging the Passport into both the front and back USB ports of the desktop, and the USB port on one of the laptops, and I’m absolutely certain that it appeared neither in Windows Explorer *OR* Computer Management | Disk Management. A week or two later I plugged it in to the desktop, and *was* able to see it in Disk Management and assign a drive letter to it (using both front and back–USB 3.0–ports), and also with the recalcitrant laptop.

I’m pretty sure that I hadn’t done anything else–I did install WD SmartWare, but I’m pretty sure that that was after. And now everything works well. I had a similar adventure with another Passport on another computer–we couldn’t get the computer to recognize the Passport. We finally gave up bypassing the 3’ USB extension that brought the port to a convenient desktop height, and plugged the unit directly into the computer–lo and behold, it worked fine. USB is generally a fairly robust technology, and I’m not completely happy with a device that seems so, well, USB-fussy.