My passport ultra not working in Usb 2.0 ports but working perfectly in usb3.0 ports


I bought a 2 tb hard disk recently, I was working perfectly for a few days.and this weird kind of error started happening.

When i connected my hdd to usb 2.0 ports it is not even recognising. first few days of this error it stated as " usb device is not recognised" error but now if i connected, the device gives like continous blink of led for few times and after it is started glowing continously.  I tried connecting in more than 5 computers but it is giving the same error.

The device is working perfectly in usb3.0 ports. but all pc and laptops dont have 3.0 ports. :frowning:

Please help. I tried searching the communites but I got no related/useful results for my problem.

Please help to solve my problem.

Info :  My passport Ultra 2 tb black.

S/N : [Deleted]

Hi, be sure to use the USB cable that came bundled with the Passport, longer USB cables or USB hubs can cause power inconsistencies. Also check if you have the latest Passport firmware installed.


Thanks for quick response.

I use only the cable provided with the product. To be frank i dont have any  other HDD or cables to connect with.

I updated the Firmware to my external HDD but its still not detecting in usb 2.0  ports.

Please help.

I tried connecting, i gives a continous blinking of led for 20 times and afterwards a constant led light. 
P.S i cant find my device in device manager, printers and devices.
My pc is behaving as if there is no usb devices are connected.

Please help.