My Passport Ultra not recognized by Xbox One


#1

I have been using my 1 TB My Passport Ultra on my Xbox one for almost a year at this point. Often using it as a sort of “compact transportation device”, so that i could play those games that i have downloaded onto the hard drive on other Xboxes without having to download those games internally.

Recently, as of two days ago, my xbox has not recognized the hard drive as being plugged in, i have tried everything on xbox’s troubleshooting site, sat through 3 different support agents, reformatted my external hard drive multiple times, made sure I was on file system NTFS, reset the xbox to factory (keeping the games installed), tried on multiple xboxes, etc. Nothing seems to be working. It seems however that xbox is the ONLY system that doesn’t detect the drive, when i plug it into my PS4, it immediately asks to reformat, whereas on xbox i stare at my screen blankly hoping that it picks it up and that i don’t have to buy another External Hard Drive.

Please help me.


#2

Hey @Spartan4665 - I recommend reposting here : https://community.wd.com/c/wd-external-drives/wd-portable-drives

This current sub-forum is dedicated to the My Passport Wireless family of devices only.

I’d also recommend trying a different HDD, if you have one on hand, with your XBOX and reaching out to XBOX Customer Support. Best of luck!


#3

I have the same exact problem. I have even partitioned it to the specified setting and honestly I have no clue what I’m doing. I have wiped it of all my games just in the hopes that my xbox will recognize it and nothing. If someone can actually help that would be great