My Passport Ultra not recognised by Windows 10

I have been using My Passport Ultra successfully on my Windows 7 laptop for a long time, however it is not recognised by my new Windows 10 laptop (Dell XPS 13). When plugged in the drive is not detected at all. (No messages about installing drivers etc. Nor does it appear in Disk Management.)

I have tried updating the firmware (http://www.wdc.com/wdproducts/wdsmartwareupdate/firmware.asp?id=wdfMyPassport&os=WIN) but it keeps getting stuck at the message ‘Disconnect all USB devices… reconnect only the WD drive you want to update’. Clicking Rescan makes it just pop up the same message again.

I tried installing WD Drive Utilities (in the hope that might e.g. update any necessary drivers) and also manually installing the WD SES Driver for Windows 7/8. (Can’t see one for Windows 10.) But neither made any difference.

I’ve also tried repeatedly rebooting Windows, unplugging/replugging the drive, etc. Again no difference.

The drive & USB cable are not faulty as they work fine on my Windows 7 laptop. Also the USB socket on my new laptop works fine.

Windows 10 is completely up to date and I had a BIOS update a few days ago.

What should I do?

Hello,

I recommend you contact WD support for assistance with this issue.