My Passport Ultra is in "my printers and devices" window but I can't find it

I bought My passport ultra today (12/21/13).  I plugged it in and the computer recognized it and loaded the drivers.  It said it was ready to go but I can’t find it.  The My passport  is there in the control panel, under printers and devices but I can’t find it on “my computer”.  The hard drive is listed under “my computer” (C drive) and the dvd removable drive (D drive) is there but no passport.  What now?

How is the drive showing on disk management?

How to access Disk Management in Windows XP, Vista, 7 or 8 to manage hard drives

Check if the drive is getting a letter assigned.

WD external drive is not assigned a drive letter by Windows or Mac OSX and data on the drive is inaccessible

Here is a pic showing the passport in devices and printers.

Next is a view of disk management.  But it still does not show up under “my computer”.

The passport is connected and the little white light on the unit is on. 

devices and printers window .jpg 

I just got off the phone with WD tech help.  He had me reformat the passport ultra on a different computer.  It worked fine.  The computer recognized it and assigned a letter to it.  I came back to my computer but nothing changed.  I still cannot find the drive.  He suggested there is a problem with my OS which is windows 7.


I was reading your  problem which is same problem I have. What solution did you get?? I can see you still have the problem with your computer. I have same symptoms with My Passport, I tried different computers and still don’t work.

Help please.

Edgar G.

The passport never did work on my computer.  The WD help guy couldn’t figure it out etiher.  I bought my wife a new computer for xmas and the passport  worked fine on hers.  I thought I’d give seatgate a try.  I’ve used them before. 

I have precisely the same problem. The passport hard drive can be seen under devices but not by explorer. I am running windows 7 and this problem has suddenly occurred resulting in all my data of the drive being in accessible.

Did anybody get a solution?

Wd help? An answer please

I have the same exact problem.  I read that the USB 3.0 driver may not be up to date.  I am exploring that possibility.

I’m having a similar issue. My Passport is now just about full, and it’s always worked. Now I need to get stuff off it, and it’s not accessible. The name comes up as “K Drive” instead of WD, and Explorer freezes and shuts down just by clicking on it. Is there a workaround to get to my files? This really **bleep** :frowning: