My Passport Ultra is Dismounting

My Passport Ultra is dismounting itself many times a day. I am on a iMac running 10.15.6. I have the energy saver turned off.
There disk is about 3 weeks old and I am not getting any help from Technical support. I am told to check and see which driver I am using and I don’t know where to check and when I go to the website I can’t find any drivers for this unit

Is it an external WD My Passport Ultra with USB-C connector?

If so, then I have had the same problem, on an iMac as well as on a Windows computer.
In my case I changed the standard WD USB-C cable with an other cable and the problem was solved.
Try to do this first before you’re blaming the hard drive, computer, or driver software.

Thanks for the response. I did replace the cable and it has dismounted three times since then. I also switched USB slots on the back but that didn’t work either. I of course run diagnostics on the disk and it cam out good.


Ok, try this one … Disable Spotlight Indexing

I did disable Spotlight completely and still had a dismount after that. Anything else you can suggest. I am using the My passport Ultra for backup. It replaced a Lacie Disk that was also dismounting. It seems that which ever disk I designate as backup is the one I have trouble with.

Next try, although I don’t think this will solve your problem:

Update the USB driver for your iMac.
Open App Store and Click on “Updates” and see if there is a new update available.

also to try:

Check USB hard drive in system information:
Click on the Apple logo at the upper left corner of your desktop.
Choose About This Mac and choose System Report.
Click on USB under Hardware in the left sidebar, and you will see all the USB devices connected to your Mac.
Look for your USB external hard drive in the list. You can see the available power for this USB hub and the required power for your hard drive exactly.

How do you make a backup?
For many reasons, I never make backup’s (using backup software) but simply copy files, one on one, to an external hard drive.

I use time machine to backup my Mac.
I have used it for years with no problems until this year and I have replaced two external disks thinking that was my problem.
I ran the system report and it shows;
Current Available 900
Current Required 896
When I go to the App Store I don’t get any results when I key in USB Drivers
I have the option forth App Store to automatically up date mu Applications.

I’m running out of options, but I found this:
Catalina 10.15 and external hard drive issues

It seems that OS 10.15 can cause the problem.

If you are very desparate, you can try this:
How to downgrade from MacOS Catalina to Mojave

Thanks for your help.