My Passport Ultra - I can not access my data

(Sorry, I used Google Translate :stuck_out_tongue:)

Hello everyone! Since yesterday I can no longer connect my 2TB My Passport Ultra.
Or rather … I connect it to the pc, turns on the light flashes or remains fixed or based on time, but does not appear in My Computer no hd connected.

Instead, the notification icon in the Remove Hardware, in the bottom right corner next to the time and date, after about 1-2 minutes which is connected to the device appears correctly recognizing me as a My Passport Ultra.
I use Windows 7 Pro 64bit. Every now and then, and only 5-10 minutes after it is connected, you will see the hard drive in My Computer but without giving me the ability, unlike other internal hd rather than pendrive that I’m going to connect.

If I try to open the hd from My Computer, the progress bar starts to color green but arrived almost at the end remains fixed in loading, even after 2 hours. Then I gave up.
Those rare times when I open Disk Management tells me that you need to initialize the disk, and if I give the ok comes the error message “Failed to execute request because of an error of I / O device.”

I tried to check the operation with WD Data Lifeguard Diagnostic many but the few times that he finds me correctly indicates how WD My Passport 0820 (USB) but the listed capacity is 0MB and the SMART Status is “? Not Avaible”.
The faster test than the advanced testends after 1 second with the result PASS.
If you try a format and do as he says “Delete Partitions error” for both the Quick Erase the Full Erase.
When I look at the results of the two tests this is what I get:

Test Option: QUICK TEST
Model Number: WD My Passport 0820
Firmware Number: 1007
Capacity: 0.00 GB
SMART Status: Not Available
Test Result: PASS

Model Number: WD My Passport 0820
Firmware Number: 1007
Capacity: 0.00 GB
SMART Status: Not Available
Test Result: PASS

(I removed the line of the serial number)

Although most of the time the WD Data Lifeguard Diagnostic program, rather than Disk Management or other programs for the diagnosis of the disks, do not start your own, even after a long time.
Then just unplug the hd as if by magic all start together, even several times if I have tried several times to start them.
If I connect it to programs already under way or is not recognized or stopped me in loading programs until it is connected.
It 's like the hd stopped every program that could check for proper operation.

With WD Smartware is recognized but instead with a capacity of 0.0 GB.

I thought it was a pc problem but unfortunately I have tried:
- All USB ports both 3.0 and 2.0

  • Cable changed from the original to another
  • Various other pc: seven with Windows 7 Pro, one with Windows 8.1, two Macs and even a live Ubuntu

Result: the notification icon appeared, rather than being recognized properly on Mac and Ubuntu, but to enter into the hd to see the data there was no way. Loading forever …

Since I used it without any problems for about 5 months I do not understand why so out of nowhere I can no longer access the data?
What other tests I could do to try to recover?

Thank you all for the help!


It may be possible to still extract the data utilizing data recovery software. There are several kinds of Data Recovery software available. If you do a  web search for  Data Recovery  it will yield plenty of data recovery software options.

I tried Recuva but as usual the hd has blocked the program.

Only once Recuva has found it but it was not possible to recover any data, an error message appeared immediately when I start the search.