My Passport Ultra 2TB Not Recognized in Windows 8.1 with USB 3.0

I bought a 1TB Passport Ultra and 2TB Ultra together. I first tried the 1TB Ultra and had no problems. When I tried the 2TB my PC didn’t recognize it in the USB 3.0 port. When I plugged it in it made the connecting sound and a few seconds later I heard the disconnect sound. The drive didn’t show up in File Explorer or Device Manager.

I plugged it into a USB 2.0 port and it was recognized and seemed to work fine. I tried a few different USB 3.0 ports and also used the cable from the 1TB drive, but it still wouldn’t work with USB 3.0. I updated my USB 3.0 drivers but that didn’t help. Since the 1TB drive worked fine with USB 3.0 I figured there was a problem wth the 2TB drive. So I returned the drive and was issued a replacement. But I have the same problem with the replacement. I am stumped as to why the 1TB drive works fine with USB 3.0 but the 2TB drive doesn’t. Can anyone offer any help or suggestions? Thanks.

I don’t know if this will help or not I’d check the MB maker’s site for any updates. If this uses a card for the USB 3 try it’s manufacturer’s site.


1 Like

My guess is that the 2TB drive isn’t getting enough power.  It could be that your computer just does not supply enough power to its USB 3,0 ports.

Have you tried the 2TB drive in another computer that has USB 3.0 ports?  Does it work there?  Or have you only tried it only connected your computer?  If you only have access to your computer, do you have other USB devices plugged it?  If so, disconnect all except your 2TB drive and see if it then behaves normally.  If the 2TB drive works when it is the only USB device connected then you can be pretty sure it’s a power problem.

USB voltage is 5 volts.  That’s the same for USB 1, 2, and 3.  However, the total available USB output amperage differs from computer to computer.

USB 2.0 ports are supposed to supply 0.5 amps (same as 500 milliamps) of 5 volt current at each port.  USB 3.0 ports are supposed to supply 0.9 amps (same as 900 milliamps) of 5 volt current.  However, some computers just don’t conform.  However, some conform if you only draw power from one or two ports.  So, you are dividing the amperage among several or all USB ports in your computer.

A WD 2TB drive requires at least 0.75 amps.

You can look at the USB Hubs in Windows’ Device Manager but they often report erroneously. that your computer is supplying only 500ma per port.  That is often entirely incorrect.  It is practically meaningless.

If power is your problem, what can you do?

You can add a USB 3.0 hub that has an AC adapter to supply power to those devices connected to it.  However, some devices don’t like to operate on a hub and I don’t know if WD My Passport drives like hubs.  Data corruption is a consideration.  I would check with WD first or just experiment on your own to see how your drive behaves on a hub for a few days.  Pick a good brand name hub with good reviews.  That hub has to “repeat” all the data bits passed through it as they go to and from your computer and drive.  Timing is critical.  Some’s good and some’s bad.  Do some googling and look at reviews at places like NewEgg and Amazon.

Better than the hub idea is to add a USB 3.0 card to your computer if it has an available slot.  If you buy a card, get one that has an extra power connector on it that lets you hook it to the main power supply.  It could be that the motherboard of your computer won’t supply enough power to inserted cards through the cards main pins.  Cards with an extra power connector can provide more output power to the USB ports you are adding.

When they say a USB 3.0 device (like a WD HD) is backward compatible with USB 2.0 and USB 1.1, they mean the data streams can be managed at all those speeds.  They do not mean that it will slow down or use less power on a port that is insufficient for its needs.

Knowing so little about your situation, these are my best guesses.  If I’m way off base, let me know.  I’ll try to think of something else.

If you find a solution will you come back and post?  I believe these things help hundreds of people who land here through search engines.

"I don’t know if this will help or not… I’d check the MB maker’s site for any updates. If this uses a card for the USB 3 try it’s manufacturer’s site."

Thanks for the reply. I didn’t think this would solve my problem because it’s a new PC. I tried anyway with no luck. I did an extensive search on the web and couldn’t find a similar occurance. I came across one posting where a drive was recognized in a 2.0 port but not 3.0. It involved overclocking and not enough power to the 3.0 port (or something like that).

My PC isn’t overclocked. And I know the 3.0 ports work because the 1TB drive works fine. But I’m wondering if it’s a power issue. Does anyone know if the 2TB drive requires more power than than 1TB drive? I’m using an Asus M51AC PC. It originally came witha 350w PSU. After I sent back the first 2TB drive I installed a 750w PSU and a new vid card. But either way the 2TB isn’t recognized in the 3.0 port.

Anyway, to sum things up, I have a My Passport Ultra 1TB drive that works fine in both USB 2.0 and 3.0 ports. I’ve tried two different Ultra 2TB drives. Both work fine in USB 2.0 ports but are not recognized in 3.0 ports. Since the 1TB drive works in the 3.0 ports I’m guessing there has to be something different about the 2TB drive, but I can’t figure out what it is.

RustyInKentucky wrote:

My guess is that the 2TB drive isn’t getting enough power.  It could be that your computer just does not supply enough power to its USB 3,0 ports.



Thanks for the input Rusty. Power seems like the only logical answer to me. I will have to get my hands on USB Hub and report back.

Based on the model of your computer which you have divulged today, I’m guessing you should be having no problems with power.  For all reading this thread, here’s a link to his computer’s ad page:  Asus M51AC

When the say Ai, they refer to charging an iPad.  Usually, that means a full 2 amps (2000 milliamps) @ 5 volts is available to one or all of the USB ports to charge devices like an IPad faster than a standard USB port.

On your computer, based on the info at the linked page, ports on the front of your cabine or maybe just one port on the front of the cabinet are/is an Ai type high powered port.  If you are plugging in there, power deficiency should not be your problem unless there is a malfunction in the circuitry of your computer.

Unless … just an outside chance … that the WD 2TB drive rejects ports that it detects as overpowered?  It might detect any port in excess of the 900ma norm as being defective and hazardous?

I have a video camera that will reject a port of that nature.  I have a wall adapter that provides standard 5v output to USB ports for charging things.  One of the ports will deliver 2 amps.  If I plug the video camera into that 2 amp port, it refuses to charge.  That camera refuses to function on any USB port that exceeds 1 amp.

In the world of computers, 2 amps to a functional USB data port is very rare.  There are many wall adapters that provide 2 amps to a USB port but they are not data ports…they just provide 5 volts of power.  But, your computer can provide 2amps of power to a port or ports that also function to transfer a data stream.  Even very few MAC’s provide 2 amps to their USB ports.

It could be that WD has designed its drive to reject anything above 1 amp just like my camera?

Are there any USB ports in your tower that are not on the front?  Maybe those not on the front are not Ai (high powered) ports?  But, you’ve already tried them all, right?

If all your computer has is Ai power to its USB 3.0 ports, and if WD portable drives detect anything in excess of 900ma as a hazardous overcurrent situation, then you might have to implement one of the suggestions I mentioned…

Let us know, huh?  Sounds interesting.  (Looks like a nice computer, by the way.)

1 Like

Just discovered that I, myself, have been hit with this problem.  The drie is obviously not backward compatible with some USB 2.0 ports.

One of the computers I want to backup to this My Passport Slim 2TB refuses to keep it mounted.  When I hook up an externally powered USB hub, the drive works fine.  Obviously, that older Compaq computer isn’t providing enough power.

Then, I tried it on my daughter’s older notebook computer.  The My Passport Slim won’t run on that either unless I inject additional power using an externally powered hub.

So, My Passport 2TB drives do not always accept USB 2.0 power.  It seems that it needs more than the standard 500ma.

Dagnabbit!  Kinda defeats the convenience of a bus powered drive if I’ve got to carry all that extra hardware to make it work.

So, thank you for your post.  Now I think we know that the 1TB drives might be truly backward compatible where power requirements are concerned but the 2TB drive seems to be incompatible in many situations.

I’ve seen a disassembly of a WD My Passport 2TB drive on YouTube.  It’s got a label that obviously states 0.75a.  That’s 250ma more than USB 2.0 standard of 500ma.

Sure enough, there are going to be many USB 2.0 ports out there that the My Passport 2TB drive will reject.

I have a 3.0 USB Hub on order. I should be receiving it in a few days. I’ll post an update then.

One thing on the power issue is a lot of PC makers use barely adequate power supplies and haven’t allowed for all of the increased USB usage today. 


I’m having this same issue on Windows 8.1. I have a Dell All-in-one XPS 720 desktop. It’s weird because the drive shows up as a device sometimes, but can’t find a driver for it. It comes up as unavailable. I’ve installed all the different software with no luck. The other thing is my Windows 3.0 hub that worked in Windows 8, is not recognized in Windows 8.1. Anyway when I connect the 2TB Passport to either a USB 2.0 or 3.0 port, it’s not recognized. I changed the power options so that power is always available but that seems to have not made a difference.

I can certainly understand having an underpowered port making it not work. However with an all-in-one desktop, that shouldn’t be the case. I loaded all of the new drivers for 8.1 from Dell but that made not difference.

Any other suggestions?

For those of you reading this, take what I tell you with adequate caution.  You know what you can do.  Me?  I play and learn.  Sometimes I get myself in real trouble.  Digging myself out of a hole is a learning situation for me.  You may wish to avoid troubles that could possibly cause you to have to entirely reformat your drive, lose your data, and reinstall Windows.  That said, here we go.

Actually, this shouldn’t present any ways for the novice to cause harm to him/herself or others …

Maybe there’s a device driver that didn’t install properly?

You could look in Windows Device Manager and see if there is any device with some icon beside it that might indicate a problem.  A yellow triangle with an exclamation mark in the middle has always been a big clue in past versions of Windows. You have to choose to view hidden devices in order to see the WesternDigital SCSI Enclosure Device driver.  (That’s the SES thing that Windows installs for these WD Passport drives.)

1 Hold down Windows Logo key on the keyboard and then press and release the x key

2 Choose “Device Manager” from the menu that pops up

  1. Click “yes” to the User Account Control warning window if it pops up

  2. Choose “view” at the top of the window

5 Choose “show hidden devices”

Now, if everything is good, then you will see that all of the “nodes” are collapsed.  In other words, there should be no parts of the tree that are expanded to show the component parts of that section.

But, are you seeing anything expanded with some sort of wierd icon beside it?

If nothing has a wierd icon, then look near the bottom. Do you see the node titled:  “WD Drive Management Devices” ?  That should be there.

Click on the arrow to expand it.  If your drive is not connected, the sub entry titled “WD SES Device” should be greyed out (greyed out means the type font and its little icon will be rather faint).

Okay so far?

Now plug in your WD drive.  Leave the Device Manager window open.

It should flash two or three times before your eyes as the newly attached device is identified and enumerated into the list.

Now, you may need to go back to the node titled “WD Drive Management Devices” and click on that node to expand it again.  At this point the sub-entry “WD SES Device” should still be there but it won’t be greyed out.  It will show up in the same dark text font as everyting else that’s good in the list.

By the way, don’t be concerned at this time by other things in the lists that are “greyed out.”  Just leave them as they are.  These should simply be things that are installed but not currently connected.

to gifcar:

Well?  Now?  That USB hub may not help at all.  Remember.: I mentioned lack of power as a possible problem before you told us what computer you had.  But, then, you told us your Asus computer model.

Based on the ccomputer model you told us, we then could see that yours is a very special computer and it not only provides the standard full 900ma to its USB 3.0 ports but it also provides what ASUS is calling “Ai” power to some or all of its ports.  I don’t know if it supplies Ai to all or just to the front ports.  But there should be at least one on your computer that supplies more than adequate power for the My Passport drives to function.  You’ll have to check your owner’s manual on this topic.

Anyway …

Ai is supposed to designate that a port provides more than 1 amp for charging things that can utilize a higher charge rate like iPads.  In that case, you won’t get any more needed power by adding a USB hub unless your computer is defective and is not supplying its stated capabilities.

But, as I did mention, maybe the 2TB models of MyPassport drives are designed to reject some value above 900ma as excessive and possibly dangerous?

That is something I cannot test for you with my 2TB Passport because I don’t have any USB port in my life that provides more than 900ma coupled with a data stream.  I’ve got wall chargers that provide only power and some of them will supply more than 900ma but they do not also carry a data stream because they are not connected to a computer.

Like I mentioned, I have a video camcorder that will not charge if I connect it to a 2amp power port of a wall charger.  I have to connect it to the 1amp port of that wall charger.  It is functioning as designed (although it is aggravating).

So … question is … that you will have to discover … are there any ports on your computer that are not Ai ?  If so, have you also tried that port or those ports that do not supply that extra Ai boosted power?

I don’t know if there are any non Ai ports, but I’ve tried all the USB 3.0 ports on the PC with no luck. I ordered the hub because it’s more convenient for me, plus I could always use the extra ports.

The hub arrived today and I am happy to report that the 2TB My Passport Ultra does work in the USB 3.0 ports when connected through the hub. It’s recognized by the PC with 3.0 transfer rates. I’m still not sure what the problem is though. Too much or too little power, or something else? I spent an extra $40 for the hub (probably should have bought a cheaper one), but I needed the hub anyway so I’m not really mad about it. I’m just glad I can use the drive with USB 3.0 now.