My Passport Ultra 1.5GB

I’ve divided disk to 2 parts, A and B. I was trying to write files on this external HDD and in the end of process a error came up, saying that some files couldn’t be read so file copying stopped. In the disk was 140GB instead of desired 500. Mac couldn’t open at all those disk and files, windows could. Then I reformatted that faulty part of HDD (named B) and started diagnostics with WD Drive Utilities. I ran smart check, quick check and it passed. When I try to run complete check with this tool after 1min or 2 it cancels automatically. I think something is wrong with HDD and I’ll need to replace this external drive, it isn’t reliable at all and I’m afraid of losing files again.

And I want to add, that this drive is completly new. I have purchased it 2 or 3 weeks ago and used to back up 200GB on it.

Welcome to the Community.

This is most unfortunate but yes, when a hard drive fails a test the best option is to replace it under warranty. Please visit the following link for additional information related to processing a warranty RMA through WD:

How to get a Return Merchandise Authorization (RMA) or replace a defective product under warranty

On the other hand you should be able to directly replace the device at the retailer if it has been a recent acquisition.


last night i checked it on HD Tune Pro and it showed no bad sectors. 100% is green. its interesting what the **bleep** did happened to my hdd

Screen Shot 2014-10-27 at 5.04.06 PM.png

same thing happened again

Now, it says that +400GB is used in B disk but shows no files


First I did quick check of hdd with WD Diagnostic Tool and it passed. Afterwards I left it to full check at evening. nearly 5 hours i was watching and then went to sleep. In the morning it says ABORTED but no one has touched it.


Did the computer or the hard drive go into sleep mode?


After 6:37 hours? Of course not! :slight_smile: I merged those 2 partitions, formatted and I’m leaving tonight on full check again. I’ll show results tomorrow

I deleted those 2 disks with widows built in disk manager, then merged and formatted it. After that I ran FULL CHECK again and it went till the end, it passed. Why this happens? Whats the problem to divide hdd to 2 parts?