My Passport. Sudden Failing. Detailed

Hi guys/girls 
I have a WD My passport and toinight suddenly it has stopped working. It has been round the world with me, on tour and not had a single issue. Get home use it and its fine, then all of a sudden it stops working.

I plug it in and it makes 4 or 5 little “rrrrr” sounds.
The LED is solid on.
My computer does not detect it is there

Maybe it is just an enclosure issue, but with the weird noise i guess its fully broken ? 

im not gunna bother with the whole Freezing it thing, but if you guys have any advice on how to get the data of of it without sending it off then i would be greatful.  

I look after it alot more than anything, i need the info on there. I have infact just ordered another one as i wanted to back everything up. . Looks like it is too late.

Any help would be great 

Well, it sounds like it’s not getting enough power over USB.

Have you tried the usual checks?

  • different USB port
  • different USB cable
  • different PC

If none of those help, you could always contact tech support and ask for a power booster cable and see if that helps.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

Hi. 
I have brought a power boosting cable last  night + a new enclosure + A new HDD :’(
i have tried all the USB ports on all of my computers at home and still the same RRRRR Beep sound. its like its spinning and the arm is getting stuck ?
I have tried  3 diferent cables,  All WD braned and 4 or 5 others that are just from diferent things. 

I had the same problem you are describing about a month ago with a my passport essential. Lost 1TB of data. LED was on, it would make a clicking noise (x8 times) on power up and then nothing. Tried on different computers and just gave up went for a replacement.

Wish the HD was SATA and the USB internal adapter was removable, at least would have a better chance to save the data.