My Passport Studio won't power on


#1

I have a 500GB My Passport Studio formatted for mac.    I have used the hard drive with the firewire 800 cable for about a month with no issues on a power mac g5. Yesterday, I tried to connect via firewire 800 cable to a power mac g4.  After starting up I noticed that the icon for the drive never appeared on the desktop.  The lights on the passport drive came on then made a clicking sound and never came back on.  I tried connecting it to a couple G5’s and even tried a usb cable thinking it might be a firewire issue.  With my hand on the drive, I can feel it running briefly while the light shines very dimly, then it stops and the light goes out.  (Update: Tried the USB cable on home G5, unit is now recognized but not via firewire 800 nor 400.  I have tried other firewire cables but they do not seem to work.  DId the G4 fry my firewire connection?)

The frustrating thing is that this is the second one I have owned as I had to send the first in for a warranty replacement after experiencing the same issue.  Again, worked well with G5 but G4 seems to have ruined it.  Is there anyway to get the unit working again?  Why the issue with G4’s?


#2

I have exactly the same problem. I have checked and have a warranty but the shipping costs to send back the drive from central america to WD is more than what i would have to pay to get a new one. :angry:  Not to mention all the lost data.