My Passport SE for Mac (1TB) - Firmware update problem


#1

Hello friends,

I’ve a problem trying to update my portable drive firmware.

I’ve bought a “My Passport SE for Mac (1TB)”, it appears to work correctly but I’m not able to update the firmware.

I’ve downloaded the WD Firmware Updater and followed all the instructions, but the firmware update process freezes and it doesn’t go on, no progess percentage is shown: after a lot of minutes I can only close updater window.

The original firmware is 1.032, and there’s no way to update it!

I’ve tried with Windows XP (SP2 and SP3) and also with MacOSX 10.5.6.

Actually I have a ticket opened with the WD support, I’m waiting for an answer… any suggestion?

Thank you!


#2

I don’t know much about Macs check the 8/16 post 47 http://community.wdc.com/t5/External-Drives-for-Mac/My-Passport-for-Mac-frimware-update-problem/td-p/17742/page/5   I know it sounds dumb updating a Mac on Windows.


#3

Thank you for your answer Joe_S!

Before posting this thread I carefully read the post you’ve linked, there was no way to solve my problem… :frowning:


#4

Support has answered to my question. It says that my portable hard drive has the latest firmware version and there’s an error in WD software.

It doesn’t sound good, I’m not convinced at all…


#5

Thanks for coming back maybe it will help somebody else.


#6

i have the same problem and wdc support respond me the the firmware is the last.

Last firmware is 2.018/2.019 and i have the 1.032 that is the initial release of WDC firmware.

Let me know, please!


#7

I think you’re up to date. Read the first post then read his finding in post 5. On top of that If everything is working I wouldn’t upgrade unless it was for security “If it ain’t broke don’t fix it”

Joe


#8

I’ve tried upgrading to the latest firmware, and cannot get it to work./1TB MyPassport Essential for MAC FAT32)

I was trying to do this on my PC (working, but never finishes). So then I even tried running the firmware updater on a Mac, and got the same result

Help me please!


#9

The mystery is solved!
In the installer
Apollo 1607E Firmware Updater v2.018-v2.019 (1.0.8.6).exe
there’s a compressed temporary file name UpdaterConfig.ini
which contains the following lines

[071A]
Model      = My Passport Essential - R2
OldVersion = 2.009, 2.011, 2.019
NewVersion = 2.019
NewFile    = Apollo_R2-2019-20101027.bta

It means that for our old models (mounting 1.032 firmware version) it is not possible to upgrade to the lastest firmware version. For instance it is possible for My Passport Essential NOT SE, as you can read in the same .ini file…

[1110]
Model      = My Book Essential - R1
OldVersion = 1.028, 1.030, 1.032 , 2.003, 2.010, 2.018
NewVersion = 2.018
NewFile    = Apollo_R1-2018-20101026.bta

I’m going to ask support why they are not clear about this statement!


#10

Wow!!

But  WD passport 1T(like mine)  is SE version ( http://www.wdc.com/it/products/external/portableformac/)

Let me know


#11

Also mine! R2 means SE (Second Edition)

[071A]
Model      = My Passport Essential - R2
OldVersion = 2.009, 2.011, 2.019
NewVersion = 2.019
NewFile    = Apollo_R2-2019-20101027.bta


#12

Hi!

Same problem here!

I have a WD My Passport SE Mac (1TB) and cannot update the FW. I have tried to update the device on several PCs with different operating systems (WinXP, Win7) as well as Mac OS X 10.6.5.

The process doesn’t start and on my Mac the Tool keeps the CPU busy with 100% load! 

The device is recognized as #070A with FW v1.032 which is the R1 version according to the ini file and should be possible to upgrade. However, I cannot update the device.

I found a very interesting entry in my system log file:

04.01.11 14:37:30 WD Firmware Updater v2.1.9.0[694] (null)

04.01.11 14:37:30 WD Firmware Updater v2.1.9.0[694] Serial Number is not in the list…

I am not sure, but I think the device should be #071A, a R2 version since it is a SE device. Therefore, I guess that the device is not recognized correctly.

Does anybody want to try to edit the ini-file in order to get the FW updated?

Best regards,

Chris


#13

Hello Bonzo87,

few weeks ago I’ve tried with .ini modification but it has not worked, update process continued to freeze… It’s not the right way.


#14

I have tried   to upgrade to 2.003 version (file found on line) but even so the upgrade never finishes.

what support has said you?


#15

To be honest unless I had issues or the firmware involved security I wouldn’t bother with the update. If it ain’t broke don’t fix it. Also this in an old post.

Joe


#16

@ Gabriel_IT

Support continues to say that there’s not a newer firmware version than 1.032 for my Passport SE.

I would like to know if there are problems with “old” drives and why they are not supported in firmware update, but support has not answered about this.

@ Joe_S

You’re right, but I’ve paid and I should have the right to know why my drive isn’t upgradable.

If newer firmwares were released it was because there were some issues in drive management, I don’t want to risk my datas, as written in the release notes
http://support.wdc.com/download/notes/Win_Essential-Elite_FW_Updater_2018-2019-1086_Release_Notes.pdf

Firmware 2.018/2.019:
• This firmware update fixes the drive’s handling of infrequent power glitches which can cause data access issues.

Firmware 2.010:
• Updated to meet the latest storage compliance (SBC3 and SPC4).

Firmware 2.003:
• European Union Power Savings Support.

Firmware 1.032:
• Initial release of the WD SmartWare VCD Manager for Windows.

I care about these updates.


#17

Why isn’t WD replying to any of these forum questions??? Ive still got the same issues all the other mac users are complaining about with the my passport essential (doesnt matter if its SE or not!!!) cant update the firmware! thus cannot install VCD and thus having a constant instable connection with the drive!!!


#18

This is just a users forum not a WD tech forum.

Joe


#19

unfortunately no news


#20

Very dissapointed with WD, releasing an updates without testing on it! just bought the external hard disk few months ago and very happy with it (“put your Life on it”). after update the firmware given by WD, it died!!!

i cant claim the waranty because they will just change one for one to you, then i will lost of my datas. the only way i can claim a new one and get back my data is i have to pay for WD specific data recover service!!!

what is this!!!

gonna throw this **bleep** away and conert to other brand.