My passport SE 1TB is no longer recognized in any PC

I’m facing a problem with my device. It was working well and suddenly stopped to work.

When I plug it into the USB port (no matter the operating system), I see the light on, the drive running (vibrating), the autorun doen’t shows up anymore, I hear the Windows sound but the drive doesn’t show up in My Computer or even in Explorer.  Various things freeze on the computer and immediately start working as soon as the drive is unplugged (e.g., driver manipulation through device manager, Windows Task Manager, etc.). I tried Western Digital Data LifeGuard Diagnostics, but the utility freezes my computer until I unplug the drive which immediately allows me to work normally with the computer. I tried to re-format but  useless (any software will freeze). I tested on multiple computers with similar results. My friend’s drive (exact same model), works perfectly on the same computers I’m doing the tests on. I can see that several people are having similar issues but there doesn’t seem to be a solution posted. I have already contacted WD service and support but they ignored me. I still have the drive guarantee.

Please help me, I don’t know what to do anymore.

hi, I have same problems with you but more serious, because I could not even have light on. No reaction from the USB when I plug the USB port

I have the same problem! System freeze when HDD is plugged in USB. Dont show any drive letter in My Computer.

In System Management - device recognized as WD My Passport 0732 USB Device

The LED light on, the drive running (vibrating).

I tried different computers and operation systems - nothing working

Help please!!!

p.s. Sorry for my eng - I’m Russian

Adding to thread, hoping it gets noticed. 

I’ve been suffering with the same issue (500GB Passport, not even a year old. I have over 300GB of stuff saved on it, so just returning it for a new one isn’t really an option unless either get everything off of it and transferred, or I am GUARANTEED that there is nothing I can do.

Thus far I have bought a new cord, uninstalled drivers/firmware and re-installed, and while it’ll recognize aftr taking forever to load, it won’t open and everything freezes/slows down absurdly until I unplug it - can’t even run chkdsk because of that. 

Any help would be awesome


I am having the exact same problem with all my photographs on this 1TB drive. Western Digital, please help!