My passport problems

WD SmartWare does not recognize the USB port that the HD My Passport is plugged into.    The USB port works with other flash drives.

When I go to my My Computer the drive also does not come up.

What do I do?

What OS are you using? If it’s Windows go into Disk Management and see if it is there it may just need a letter.


Using XP.  I just uninstalled the WD app but I cannot even get my PC to recognize new hardware.

I’m having a very similar problem. The SAME problem actually. But let me be more specific…

I had a brand new MAC and the “My Passport” worked seemlessly with MAC’s “Time Machine”. I was happy but…

I plugged the “My Passport” into my ‘PC’ and the problems started.

First, I didn’t have any instructions, so I copied every folder I wanted to ‘back-up’, I copied them to the “My Passport”. That seemed to work but was a long, tedious operation. I thought, “There has got to be a better, faster way.”

So, I erased all of those files (on the “My Passport”) and tried to use the Windows Back-up command.No luck.

So, I took it back to the dealer who did something to it and returned it to me. He stated (in his broken English) that the “My Passport” will now work with either any PC or a MAC - However, it will no longer work with MAC’s “Time Machine”. With the language barrier, I could not get details but had already decided to use this with my ‘PC’ only.

Got home and plugged it in. This time my PC was able to locate the “mass storage drive”. Things seemed to be going fine until about 2 hours later, I got a message that said "You’ve run out of space _ or _ your “.bkf” file is too large for this device. The latter being impossible.

Another message soon 'popped-up saying “If this disk is formatted with FAT32 - the Maximum possible size for the back-up file is limited to 4 GB.”

4 GB ?!!! This “My Passport” was rated at 500 GB! Well over the size of my hard drive!  Well, there is good news and bad news.

The good news (???)…

Back to the dealer I went and asked where exactly is the 500 GB that I had purchased. He tried to draw a simple diagram but it was ‘lost in translation’. He tried to explain that if the drive was formated with FAT 32, you only get 4 GB of back-up space. (WTF?)

More good news(???), if the drive is formated with NTFS you can get a full 500 GB of storage. And he promptly reformated the “My Passport” using the NTFS format. Thank you, sir!

So,I’m back home again, and the bad new is…

Once again, my PC does not recognize the “My Passport” unit when I plug it in. Even worse, if the “My Passport” unit is plugged in when I boot-up my computer… I have to unplug the “My Passport” and perform at least the “hard boots” before my Windows start and then…

Windows detects a problem and tries to run a “routine” (check-disk or something) on an unspecified USB drive (the drive where the “My Passport” has been plugged in. The ‘Check-disk’ routine never gets past the zero point.

In conclusion, I thought that this would be a great option to have for any computer, yet,  I have made three trips back to the dealership where I purchased the “My Passport” and have wasted (literally) days of my time tryingto get it to work on my PC.

I hope that there is help out there for me and others but at this time, my suggestion is to beware of this product.

Your initial problem was the drive was formatted for Mac it wouldn’t work on Windows because it uses a different format. The simpelest free fix to use on both is to format NTFS (for Windows) Then go to Apple site and find NTFS-3G and install on Mac. That will allow the Mac to read and write to NTFS drive.


Just to clarify, FAT32 has a maximum file size of 4 GB, no matter which drive you have.  However, you can have as many 4 GB or less files as you like until you use up the full 500 GB.

However, having to unplug the drive before Windows will boot is a problem some people have had with this model.  The problem is that the firmware interferes with the booting process.  Some have had success with a workaround by disabling boot from USB and Legacy USB support.  But the better question is why should you need these workarounds?

The right solution is to buy another brand of disk drive until WD diables the firmware in thses drives.

OK I am still having issues.  I can’t get my computer to recognize the drive when I plug into the USB port.  I am using XP. 

Anyone have any suggestions?

Go into disk management as administrator.  Can you see the drive there?  You may need to assign the drive a drive letter which you can do in disk management.  Formatting probably wiped out any previous drive letter assignment.

How do I assign a drive a drive letter?

I am unable to locate the external drive on my old Dell computer.  Using XP

As administrator, go into control panel.  Click on Administrative tools.  On that screen click on computer management.

On that screen click on disk management.

If you see the drive, right click on it.  A menu will pop up.  Select change drive letter and paths.

1 Like

I don’t see the external drive listed at all.  I’ve tried going to Control Panel to Computer Mgement/Disk mgement but I dont’ see it listed.  I talked with someone on Thurs. and they suggested I update my computer which I have done.  I have no problem locating flash drives when I use them.

Joe S.

As I stated earlier, my “My Passport” worked on my MAC , however, I don’t use the MAC anymore.

I use a PC with Windows XP.

1.) If the “My Passprt” is plugged in when I boot-up, the"My Computer" will not recognize the drive AND my internet connection (AIS AirCard) shuts down.

2.) If I plug the “My Passport” in after the boot-up, the “My Computer” does not recognize the drive. When I so a ‘search’ for the drive ( in my case ‘L’)  a message pops up saying that it is not an appropriate file.


Been there , done that but still no luck…

However, when I try the “eject” (Safely Remove Hardware), it does show a drive without a ‘letter’. I click that one but the “My Passport” light does not shut-off and a pop-up says that something like “That is not a drive being used - do not unplug”.

Still lost…

And if “My Computer” still does not list the drive… ??

Live support would be your best option try calling WD tech support and have them walk you threw the procedures of getting the drive recognized here’s a link

makeshift,  if you are using IE9 please visit the link below: