My passport problem


#1

ok well for some reason today my passport wont show up in the my computer folder at all …any idea?


#2

Hi,

I had the same problem happen today 2/5/10 with a 250GB hard drive I bought about 2 years ago.

I have an old Dell computer with XP Windows.

Up to now it always showed the device on some drive, but not today.

The Installation Wizard was looking for software to load for the “New” hardware!,  but could not find any.

So, if I find an answer, i’ll post it for your knowledge.

Thanks,

boeing_retired


#3

OK, I am having the same issue…in fact, when i have it plugged into my pc the light blinks non stop.  I have been digging around on the net and others are saying it might be that we havea  virus or spyware on the drive.

Did you guys figure this out?  It is killing me as I have all of my digi pics on this thing!!!

Suggestions?  Is there a safe mode or something like that?


#4

OK…I just got off the phone with support and basically, he told me my drive was defective.  The good news, they will replace it.  The bad news, I have to pay a data recovery company an arm and a leg to get all of my data back!!!  Totally ■■■■■!


#5

i did a little more reading and researching and found that mine will need tobe replaced also . hen i plug it in it spins but i can hear it clicking so yea im gonna hav to getit recovered then replaced a company near me charges 250 for recovery and if its unrecoverable they only charge the $40 consult fee


#6

give this program a try…Nucleus Kernel FAT+NFTS…

I tried it this aft…and it actually found the drive and I am going through the recovery process now.  It has been running for the last 7 hours.  It appears to have found the files…but still running.  If it recovers, you buy the software for something like $60.  A deal if it works.

I will post back later to let you know…fingers are crossed!


#7

I had this problem too and was really upset.  But I did “Alt + Ctrl + Delete” and went to “TASK MANAGER” and then clicked the tab “Processes” and then clicked the tab labled Image Name to catagorize them by name and found “WDSmartWare.exe” in the list and clicked on it once to highlight it and clicked end process.  After I did that I unplugged my WD  Passport Essential and plugged it back in and it came back on and was recognized and all my files were still there.  I hope this helps.  I use Windows XP.   p.s  I don’t know if that is the safest  thing to do but it worked for me.