My passport powered, but not recognised on Mac at all

My Passport is definitely getting power but isn’t showing up on my computer at all. I’ve tried it on a couple of different Macs, the USB cord that I’m using is brand new. I’ve also tried downloading driver software. Help?!

  • Can you provide us with the exact drive model?

  • Also have you test your drive in a PC?

It’s WDBABM7500ABK - 00 and yes, I have tried on a PC.

  • Is the drive spinning?

  • do you feel the unit vibrating?

Is seems to me like a power issue the drive is been seen in one computer, if the drive is faulty you won’t be able to see it in the other computer.

Solution to this problem?

I’m having the same issue. I feel the vibration and the LED is on, but my Mac isn’t recognizing it. 

The solution i found was use ‘MacDrive 8’ by Media Four to access your drive on a Windows machine and to recover all your data that way. This is an issue with some of these WD drives.- they randomly eject or become invisible on the desktop. It is heavily documented on the user forum too. I wrote up this problem  in my earlier post on ‘unmounting’ drives. I beleive it is a problem with the WD SmartWare software.

Hope this helps.

I tried the MacDrive 8 and can’t see the drive on that either. When I connect to my MacBook Pro I get a box asking if I want to connect to the Mac, the PC or BAD PCB #8. None of those brings up the drive.

If I send this back to WD will they be able to retrieve the data and place it on a new drive?


They definately wont retrieve your data!

You will have to do that yourself or hire an expert- there are links to data recovery specialists on this site- it’ll be expensive. All WD will do is send you a replacement (a re-conditioned drive if the reports around the web and on here are to be believed) and that is that.

Did you try Mac Drive8 on a windows machine? It worked after I updated it to v 8.07.38. Once you have it installed it should say ‘Explore Mac Discs’ et voila…