My Passport Not Spinning

I transferred about 300gb onto 1tb my passport hdd. ejected it perfectly and never worked again. i tried other cables, other computers (both pc an mac), and all possible usb ports. it does the same thing each time…

it sounds like its trying to start up, but makes some kind of error sound. it tries about 3 times, then it just gives up. the light is on. on mac it is not detected what so ever, disk utility search was done, but not recognized. on pc it is but only as mass storage usb, and not as a driver. it shows under “devices and printers” but not as driver. in disk management it appears as “disk 1. not initialized”. at first it appeared as if driver was missing, so i downladed the ses. the only difference now it that in “devices and printers” my passport now shows up with a favcon of what the drive actually looks like. 

drive has never fallen or had any sort of impact.

help, please. graduation depends on work inside this drive!

I also know that corrupted firmware (or missing?) can cause symptoms like that of a damaged head when its not. I do know that before I ejected I deleted some files i didnt want. could it be that i somehow deleted a file directory or some other important file?


Try some basic troubleshooting:

1- Disconnect the drive from the computer and restart the computer.

2- If the computer is a desktop, connect it on the back USB port (directly to the computer, not through a hub).

3- Go to "Disk Utility” to verify if the drive shows up there.

If the drive shows up in Disk Utility but it is not seen on your desktop, then it means the partition is corrupted and you will have to format it in order to use it again. Please note that formatting the drive will delete all data stored on it.