My Passport Not showing up

I’ve had the 320 WD My Passport for about 3 months, its been stationary on my co-workers computer that entire time. He ejected the disk–>unplugged the drive and gave it to me to transfer some files onto. I take it to my machine and plugg it in…it never shows up (light is on and drive is humming). I have a similar drive so I swap cables thinking that might be the problem. Still no drive visible. I open up disk utility and the drive isn’t in there either. I take it back to my co-workers machine and it doesn’t show up there either (not in disk utility as well). Now I have thsi drive and i just don’t know what my next step should be? Any help would be appreciated.


Hello, since you have already tried using another USB cable, it is possible that the drive could have suffered physical damage, if this happened the Mac wont recognize it. You can check the warranty for your drive on the link below, in case you need to replace it.

Warranty Check

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty

Thanks for the quick response.

It is out of warranty… By 2 months

For some reason I don’t think it is damaged. Like I said, its been stationary since it was purchased. And the sound coming from the drive, when plugged in, sounds exactly the same as the one next to it (which is still working and identical). Are you suggesting that the drive is physically damaged from normal usage? If thats the case then that is a bit strange, since the drive has only been attached to a machine for approx 1 month. Is that all the usage that is expected from these?

-I’m guessing that your not recomending any diognostics because its not visible in the disk utilty

-I’ve also read in other post that a sign of a physically damaged drive is that it will show in the disk utility, but unable to mount? Is this not the case?

Just throwing things out there.

OK… Strange, as I am typing this message I try one more time plugging it in (after it had rested over night) and it is now mounted on the desktop…

Does this mean my drive is dying?