My Passport not showing up in My Computer

I bought a brand new WD Passport Ultra to move my files to a new computer (transferring from Asus to Lenovo). I used it once to transfer all of my docs. I tried using it again to move over my itunes library, but it is not showing up under My Computer any more in any computer where I plug it in. When I plug it into a computer, it lights up and I still have the “eject” option on the bottom right corner. It also shows up under “devices and printers” in the control panel and when I troubleshoot from here it says that it is working properly.

How can I fix this issue?

Hi, Have you tried using a different USB cable? Can another computer recognize the drive? Have you go into device disk management and see if its in there?

Thanks for the reply. I have tried it on 3 different computers. It appears under Devices, but not under My Computer. I did try a different USB cable, although this is a brand new drive so I don’t see why the cable it came with would suddenly stop working.

I am also facing the same issue. Do let me know the resolution for this, if you find any.

Also having the same issue and have not yet found a fix

I too am having issues and this seems to be a common problem. Any phone numbers to call for live support?? I don’t understand how this can even be an issue.

I have a MAC and PC. Neither will recongize my drive. Any solutions out there???


Please see the WD Support site for contact information.

i have the same problem too. any solution?