My passport not registering

Hi everyone,

Today I was organizing some pictures on my passport. Everything was working fine until I went to eject the device. Suddenly, the computer wouldn’t recognize it. When I plugged it in again, it crashed the computer twice and the third time check disk did a scan. Almost all file fragments showed up as unreadable. Eventually, it started deleting orphan files. At this point, the computer crashed.

Now, when I plug it in, the passport starts up (light comes on, I can feel it spinning), but the computer doesn’t recognize it. I’ve tried it on several devices, all running windows 7. Nothing. It also doesn’t show up in any other capacity using the device manager. It w asn’t damaged in any physical way, working fine one second, and then not the next.

Usually, I always do double copies, but at the moment, I’m traveling and was only able to bring one hard drive. These are all my travel pictures, and they mean the world to me. Is there any chance that they could be recovered, and if so, what kind of pricetag am I looking at? Is there any way I could do it myself? I’ve downloaded a free recovery software, but since I can’t even see the disk, it’s not doing me much good.

Any help would be greatly appreciated. If you have any ideas, please let me know. Thanks. 


  Plug in your bad HD and check your device manager list to see if you have the following device: “Initio Combo Device Class.”  If that is the case then you are in the same boat as I am.  You may have corrupted firmware and might be able to update the firmware using WD Firmware Updater.  It didn’t work for me but has worked for some people on this forum.  Here’s the link to the directions/download:

I’m not sure which passport you have (if you have 750Gb and up then it’s probably a My Passport SE…if it’s lower then it is a My Passport).  Once you click on the proper link for your HD, click on Smarware & Firmware update (they have a windows version and a Mac version).  Download the updater and follow the directions step by step!  I read one forum where a guy didn’t do the last step (in his case unplug his my book and plug it back in).  Once he redid it following the directions it worked like a charm.  Unfortunately for me, I can’t even get past the first step.  Hopefully you have better luck.

Hope this helps!