My passport not recognized...Possible solution

I bought a 1TB My passport yesterday. I plugged it in and everything was fine. I left in running all night doing my first back up.

I decided that a complete backup took up more space than I wanted to, and wanted to switch options.

Thinking I was going to be deleting the image already saved, I used Drive Utilities to erase it.

That’s when the fun started. It gave me a message saying it was erased, then it disappeared from windows explorer.

I tried everything, rebooting, ejecting, installing in device manager…Nothing I did would bring it back in windows explorer.

So, in summary…

 I could see it in device manager by name, no errors.

I could see it on my task bar, with the option to eject.

I could see it using Drive Utilities, test it using diagnostics, all passed, and showed correct drive name and size.

I could see it using Smartware, but only option was to eject it.

Would not appear in windows explorer.

Since I still had the utilities icon, I was playing around and for giggles, I selected DRIVE ERASE again…

It did it…and as soon as it was done…THE DRIVE APPEARED in windows explorer!

I know its not the best option, but if you think you have lost it all anyway, and aren’t getting any help…might be something to try.I was lucky and didn’t lose anything as I was still in the “playing” stage, but it worked.

Good luck!

1 Like


Are you able to see your drive in Disk Management? Is the drive allocated?

Also if you connect the drive in a different computer what happens?

I am also having same problem and not recognized by ant any computers. but showing in disk management. please help