My Passport not recognised

I have a 1 Tb My passport which for some reason isnt being recognised… I plug it in and the disk spins and the light is on, but i cant access the disk… Now i have alot of data on it which i dont want to loose, and currently the only way of making it work is a reformat. Is there any way of taking data off the disk before i format it? Or is there any way to get it recognised again?

Also, my computer is 3 years old, maybe it dosent have the right technology to run the program? but it has been working since i bought it (2 months ago)…

What ive tried,

Usuing the disk on different computers x3

Restarting my computer

Usuing different usb ports

Any one help me?

It looks like WD passport has terrible problems and it could be a manufacturing problem. Maybe the WD peopel take the faulty ones back and give new ones? This could be prestige problem…

Yeah. It would seem like -alot- of Passport drives have crashed in a very short time, leaving me to think there’s something very seriosly wrong with them. One or two is normal, but I’ve seen this being asked several times a day since I posted my own problem a few weeks ago. We really need to take this up with WD.

Yeh, i only bought mine a month ago… O well, im trying to do some data recovery now, usuing spinrite but its realllly complicated and theres no good tutorials… Anyone know of a better data recovery tool to use?

If the drive shows in Disk Management then something like TestDisk might work. Some have also had luck with Easeus Partition Manager the free one


^Tried both^

My drive is comming up in disk management, in ‘RAW’ format. Ive tried both products, test disk can see the disk but when i try to recover it cant do it… I also downloaded a program called Easeus Recovery wizard, but that program isnt even able to see the disk… Any other thoughts? Otherwise im gona just have to take it to a Recovery Specialist, which will cost like $60…

Ok, im desperate now. Got every type of program, tried every tutorial, done everything possible… So i gave up and went to reformat it, but it wouldnt let me, it just said that the drive could not be formated. So now i cant do anything, cant recover my files, cant reformat.

The Format of the hard drive is RAW.

I cant Reformat it, when i try it says ‘unable to format’

Device shows up in Disk manager.

Tried lots of recovery/reformatter programs.

So here are my questions:

Am i able to get another one with my warranty?

Anything else i can try?

Try this  It’s actually to convert from FAT32 to NTFS but simetimes if fixes a Raw partition.