My Passport Not Detected

i need your help on how to fix this i recently bought a my passport Essential 500GB USB 3.0. i had this for about 8 months i was unlucky - i cant use the user/end dealer warranty cos i peeled of the sticker on my hard drive. so here’s the problem. 

while i was using my hard drive it suddenly stopped working. then the next time i used it. i cant access my external hard drive. my computer can detect my hard drive but i cant access it, open or do anything. a message always pops up every 3-4 mins saying: you need to format the disk in drive before using it. but even if i format the disk it says that windows is unable to format your disk. 

so whats the problem? i really need your help.

Whenever this happens it’s because the partition is corrupted

in this case is not even able to format…

You can try to run DLG to erase and repartition the drive

1 Like

I just had the same issue with my 1 TB external, was running fine, then I installed the new firmware/smartware and it took a dump on me.  Couldn’'t find the drives, couldn’t initialize disk drive, etc…  The only way I could fix the problem was to restore my computer before I installed new firmware and smartware.  Only WD driver I am using is the SES driver, no firmware or smartware upgrade.

Pulled up disk managment after the restore and was able to finally intialize  the drive after a couple of attemps.  I deleted the volume of the drive to one partition, one drive.  Formatted in NTFS said it formatted but never did.  Wasn’t sure how to fix this, didn’t find much in the forums so I formatted again and partitioned into two drives.  One half of the partition formatted in NTSF, and the other half wouldn’t after Windows 7 telling me that it was formatted in NTSF.  Tried again but formatted in GAW format, which is a general format but not good for PC backup.  Went from GAW format and Converted to NTSF, both partions running great, no issues.

I tried for two weeks to get the drive to work with WD’s software and updates and couldn’t get it to run.  Hope this helps, worked for me.

i will try, hope this works

may ask where can i fing DLG?

i’m still having trouble fixing my external hard drive.

 it keeps on disconnecting from time to time and it comes with a message " you need to format your drive before using it" and its gets pretty annoying.

i tried using disk management and WD quick formatter.

i really need your help.

Try  Testing the Drive with DLG

you  can also try another cable 


I cant access my WD hard drive, each time its connected to the system, it will try to install and later say the device is not detected. this has being happening fo a long time now.

Kindly assist.