My Passport Not Detected

I have WD My passport 500 GB

when I plug the cable My passport light is working but my computer not reading the files 

in the device manager I can see my passport 

but when I open the disk management is just keep loading 

I have ASUS notebook when I open the Bois options I have easy flash 

I open the easy flash and I saw my passport and I can explorer it

but when I open the windows is not detected

please I need help I have important files on it:cry:

I have the same problem with a 3.0 essential passport. It works perfect on windows7 but i cannot run it on windows 8.  Sometimes its recognized, but will disconnect after a minute. 

I do not have any usb energy save options enabled. I also talked to support which was no help at all. Any one has an idea?

It stat spinning, led is active but its just not recognized.

i hape they will reply soon

Hello all,

As a recommendation, you can try the following steps.

First, check your Device Manager to see if anything shows up with a yellow question mark or exclamation point. If you see it then go ahead and right click it then choose “Uninstall”. After doing this unplug and plug it back into your computer or restart the computer.

  • To access Device Manager you need to right-click on My Computer, then left-click on Manage, then choose Device Manager on the list from the left column. You will want to check under Disk Drives and Unknown/Other Device’s.

Second, go to Disk Management and check under Disk 0/1/2 etc. and see if any show WDC or something like this. This will tell you if the drive is formatted and healthy.

  • To access Disk Management you need to right-click on My Computer, then left-click on Manage, on the left hand side of the screen left-click on Storage and then left-click on Disk Management.

Has it been Partitioned and Formatted?

If your Passport isn’t recognized, you will need to try connecting your Passport with another USB cable, as well as to another computer ( desktop would be preferable and use USB port on the back ).

  • When used with laptops there may not be enough power currently supplied to the machine’s USB port. Some computer systems only supply 500mA of power through USB ports. The WD Passport hard drive requires a little over 1000mA of power at spin up.

If the Passport drive is connected to a USB hub, try connecting it directly to the computer’s USB port.


@ asbest


If the drive works on another computer, then the problem most likely lies with the computer that you are using. Make sure that you have the latest driver updates and Service Packs for your Windows. If the drive is still not recognized, then you can try reinstalling the SES Drivers for the unit on the Windows 8 Computer.

Hello and thank you for the reply and callback. I work in the industry myself in an international helpdesk for a very large consulting company. Iam in charge of windows 7 enterprise and a lot of other microsoft systems. I have a windows 7 certification from Microsoft.  I Work in the industry for almost 10 years. Just to tell you i can give you all information you need.

-My device manager does not show any yellow question mark

-The disk manager also does not show the hard disc . There is also no pop up notification coming up when the hard disc is plugged in or anything.

-when pluging in i also checked system and all other event logs but nothing shown there.

Indeed the USB Devices does only deliver a max of 500 ma per USB port but when the hard disc is plugged in the white led turns on flashes and stay white. For me a sign that its provided with power.  

I tested right now on a windows 7 desktop machine. In the USB Hub power settings it showed the same amount of power. 500 ma per port. For me an indication that the issues may rely on the operating system and therefore the driver and not on the provided power of USB.

I will need to test it again on windows 7 laptop in my company. I dont think that my laptop in my workplace where the disc is functioning is able to provide more power but i will tell you tomorrow. The only difference on these system is the operating system in my point of view and i do not want to install win 7 on this laptop just to test if its a failure of the os.

I heared about a tool AI charger from asus. It provides more power for a usb port. This was coded so iphones and those devices could be charged. It works on almost every system. Cant tell you to code something like that just for this case but it could be an option for people who face the same problem.

I hope that you maybe come up with another idea because the tips you provided were already double checked by me.


I am also experiencing this problem and it is incredibly frustrating.

I have just bought a new Dell laptop with Windows 8. My Passport hardrive is simply not being recognised, or even showing up, when I plug it in.

Again, the LED flashes and the device ‘buzzes’ as it should do, indicating power through the USB port.

The device and the cable are fully functional as the hardrive does work in my old laptop (Dell - Vista) and on my Windows 7 PC in work.

I have followed the steps that you have recommended in this message but to no avail. A colleague of mine has suggested it could be something to do with access rights? If so, can you advise on how I could go about correcting this?

A swift response would be greatly appreciated!

I did another check on my win 7 laptop at my workplace. It has also only 500ma usb port. The drive works perfectly so we can all safely say that this is not a problem on “my” laptop but general on windows 8 with these drives.

Another info. I have deinstalled all kind of software regarding power saving. All USB Hubs are set not to suspend to save power.

The system runs on performance. No energy saving options at all. 

Thanks for the call back again. I cannot upload my event logs. They have more then  8 mb. I cleared them today. I will upload them tomorrow evening.

Please also note that i cannot edit my RMA case probably due the fact that it was already closed or the warranty run out in jannuary. In tab “registered products” the symbols which should be links are none. When  i open the case and press edit there no box where i can add aditonal text.

i did all that before but still nothing 

and when i open Disk Management it’s just keep loading


I have the same issue.

My product number is WDBPCK0010BBK-01

1 tb 3.0 external drive

I borrowed a 3.0 cable from a co worker who has a wd  3.0 external to isolate the issue and I received the same results

steady light on drive, not detecting the drive, not bring up the drive letter

If I go overnight without using the device, it will charge and detect the drive and open the files but its only for about 30 seconds.  If I install while I have a second external on another usb slot on the machine, it will disable the second drive.

Same problem here.

It worked fine on my Win7 machine for a couple of weeks, but not now.

Even WD LifeGuard Diagnostics finds it to be good, but I cannot access it through Windows Explorer.

It works fine on my Win XP machine at work.


Similar problem (sometimes I can use hard drive, but after while computer auto rejects it, sometimes I can’t even open it, then computer restart helpes, but not always) on my new ASUS K55 laptop (Windows 8) at home, and no problems on older desktop PC in my office (Win Xp). WD guys don’t sleep, please help.

@ skaiciukas

Let me see if I get this right, the drive works on a older computer but not a new one? If that’s the situation, you might have a power issue on the laptop.

As a recommendation, try contacting WD Support over the phone. I’m sure they will assist you to get a power booster cable that will provide more power to the drive.

Also, make sure that the USB Drivers on your computer are up to date, as this may also affect the functionality of the drive.

 @ ChrisLevo

The Windows 7 computer is a laptop or desktop? If is a desktop, make sure to connect the drive to the back USB port of the computer as that will provide more power to the unit. Also make sure to use the original cable that came with the drive.

@ Harpz,

Does this happens on any computer? laptop or desktop? How is the drive showing on Disk management?

How to access Disk Management in Windows XP, Vista, 7 or 8 to manage hard drives