My Passport no Longer Recognized

I have a WDBACX7500ASL - 00 My Passport External USB 3.0 Hard Drive.  It’s been working fine, but now suddenly it no longer appears in My Computer.  I’ve tried it in Windows 7 and XP on four different machines on both USB 2 and 3 ports.

Each time with Windows 7 (on different PCs) it does a Driver Software Installation -

USB Mass Storage Device Succeeds but

Disk Drive

and

WD SES Device

…both fail.

There essential data on the drive that I need?  How can I get it back?  From reading it sounds like the proprietary connector means I can’t install it in a different enclosure…

I have the same problem. I’m currently looking for a data recovery company. A good one is hard to come by. Could cost anything between £300-£800
Have you tried a different cable? Is it clicking?

Bekkk,

Thanks for the reply.

  1. Yes, I’ve tried a different cable - Made no difference.

  2. No, it’s not clicking.

Man, I really don’t want to have to pay for data recovery… Sigh.

No me neither

If it’s not clicking is it making any noise? Has it got a light or anything on it?

Have you tried the minitool data recovery software at all?

Hi i have the sam problem, i have a passport essential and it has all of a sudden stopped working, it does make a sound when i connect it to the computer and the light comes on but i get a message saying USB dvice nto recognised. Any help appreciatd as i have loads of photos stored on it.

Have you tried a different cable, different USB ports and a different computer?

Thanks for the responses.

If it’s not clicking is it making any noise?

When you first plug it in, if you hold your ear to it you can hear it spin up

Has it got a light or anything on it?

Yes, the white LED is lit up.

Have you tried the minitool data recovery software at all? …

I don’t know anything about this software.  Where do I find it?

Have you tried a different cable, different USB ports and a different computer? …

Yes, yes and yes.  Both XP and Win 7.

I have created a series of screen captures showing the various things I’ve investigated.

The screen captures are jpgs located here: http://members.shaw.ca/glave/western_digital/

I have the same problem with my 500 gig passport. Everything has been working fine for 2 years now, but in the last week, my computer hasn’t been recognizing my passport. Its not recognized on my GF’s computer either. When I plug it into my Playstation, it is recognized, but runs extremely slow(It only has about 300 gigs of info on it).

I have a feeling the problem originated from a movie file that I put on the Passport. When I moved it from my comp to my PS3 to watch the moive, I noticed the passport was running extremely slow, and when I tried to plug it back in to my PC, it wasn’t recognized and hasn’t been since. I tried to delete the movie file using the PS3 today, but I was unsuccessful.

Hopefully we can find a fix for this.

mine’s problem is the same as well. it worked perfectly fine for few months now, but after i turned off my computer last night and switch it on earlier, my computer keeps on saying installing drivers for the passport 0730. afterwards, it will finish installing drivers however, when i open My Computer, it does not show anything for the external hard drive. 

i google some helpful tips for this:

go to control panel>administrative tools>computer management>on the left side, go to disk management

you’ll see at the bottom part a disk, mostly named disk 1. but it says not initialized.  liz snip.JPG

when i right click disk 1 it only has these clickable options: initialize disk, 

when i initialize it, it shows this

liz2.JPG

what to do now???

Here is the minitool data recovery tool, wd also have their own software and there are others if you google it:

http://www.minitool-partitionrecovery.com/

This will help you recover files if the hard drive is detected at all in my computer. Make sure you have somewhere to store therecovered files, not the original drive.

If your hard drive is not recognized at all it needs to go to a data recovery company. They are expensive. You sound like you have the same problem as me and I have just had to admit defeat and send mine off.Mine was whirring & lit up. I stopped using it to avoid any more damage. I will let you know how I get on with the company I sent it to. If you send yours away google the company first and check the reviews.

Hey Guys,

Hoping that you can help me.  I have the 500 passport and it was working fine, yesterday I turned on my comuter on it is not appearing in “my computer” most of the time, however, sometimes it does, and most of the time when you go into manage devices, it shows up as my K drive, but wont let me access it.

The little blue light is on permenantly and the fan inside sounds normal, it boots and run.

Any ideas?

Scottie

Thanks - The minitool won’t work as nothing appears in My Computer.

It’s frustrating that WD hasn’t been more helpful - Their solution seems to be to get an RMA or go to data recovery.

This “feels” like some kind of simple software problem - And that there’s likely some kind of simple solution that evading everyone.  The drive isn’t clicking, it whirs, it was working fine.  It’s not exhibiting any of the standard signs of hardware failure.

I also wish I could slave it in another enclosure or PC, but sounds like the proprietary connector means that’s not an option…

You can try using this software - I’ve had a few drives fail and this software has been able to help me get the data off in each case:  http://www.easeus.com/datarecoverywizard/

With this software, you are able to run it against your drive to see if you can get data and let you download a small subset to test if it’s working.  I’ve found that I’ve had to try different options for recovery for each of the drives.

Hope this helps.

sandmeister

Note: this only works on a PC, not Mac.

I have a feeling a power surge may be responsible for mine. Recently had electricity board out due to a damaged connector outside causing flashing lights in the house. My sky plus box has also gone. I can’t understand why it would suddenly stop working. Won’t get stung again tho I’m going to use one of these file hosting services. Still waiting to hear back from the data recovery company about my drive…

I’m starting the troubleshooting process for this problem for a friend of mine. Here is what I have learned so far:

He initially had the SmartWare software installed, but deleted it based on advise of a less than knowledgeable person.

After deleting the software, he could no longer access the partition which had previuosly been f: on his laptop.

I brought the drive to work with me and hooked it to my HP desktop running Windows XP, he was running Windows 7. Significance? Probably none.

My machine recognized the drive and began to install drivers. I ignored the Install Drivers Wizard. XP did fine on it’s own.

After completing driver loading, Windows began to scan the drive for content.

The drive works perfectly. All files he thought were lost, show up in XP on my machine fine. I feel this is a software/driver problem on his laptop. I have attempted to uninstall all drivers through his My Computer/Device manager with no joy.

Next step will be to back up his 100G of data to my hard drive. Reformat his Passport using WD Smartware and recopy his files back.  WD should address this it is definitely a recognized problem. Hello WD, are you  there?

i have the same problem but my hard disk works perfectly fine with windows XP computer in my office [deleted] but it doesn’t get detected in my windows 7 PC at home… has someone discovered a solution to this problem?

Have you recently attempted to use the drive on a Mac?  Or, have you reformatted it at all?  If so, on what OS did you format it on?

I have reformatted my hard disk but thing works fine but until you copy a bunch of files on it, it automatically disconnects it self and all the files you put in it are gone… what a product! thanks a lot WD!

You still didn’t answer my question.  Have you attempted to use it on a Mac, and what OS did you format it on.  And how did you format it?  Did you delete the partition, recreate the partition and format; or did you just format it from Computer?