My Passport no longer appearing since Windows 10 update

Hi. I have a my passport 1TB. It worked fine, and still does work fine on a Windows 7 PC but when I plug it into my Laptop (that i have used it on for a year) I get the ‘beboop’ noise that Its plugged in but nothing appears in explorer.

It appears in the device manager. Digging further it says the device 'error 10 could not be started.

I have uninstalled, restarted and updated drivers…

I am suspicious that a windows update happened at the end of last week.

Any light from anyone? Anyone have the same issue?

BTW mypassport ultra 2TB working fine on said laptop and PC

It could be a driver issue.

What happens if your disconnect your system from the internet, uninstall the current drivers, reboot your system, and connect your hard drive while still leaving your system disconnected in order to prevent Windows from downloading drivers related to the update?

Thanks Trancer for the idea. I though it had fixed it but Alas being more methodical it failed again so here is the latest puzzle.

Uninstalled drivers, disconnected internet. Restarted. Drive connects. Yipeee.

Remove drive (properly) then plug back in (to the same port it just worked on) and nothing, Beeboop that is plugged in but not appearing in explorer.

It does appear in device manager with the following message.

This device cannot start. (Code 10)
{Operation Failed}
The requested operation was unsuccessful.

The driver it is running is
Microsoft
21/06/2006
10.0.14393.0

Which seems really old. Any ideas anyone?!

Hello Richard,

I suggest you to go through this https://www.lifewire.com/how-to-fix-code-10-errors-2623181 blog to get to know how you can fix Code 10 hard drive error.

Thanks again for the input. Still no pattern I can spot here.

uninstalled everything, re installed. On the odd occasion it works mostly not.

It Beeboops to say it’s plugged in, appears in device manager but does not appear in explorer. Occasionally it appears in Device manager with the code 10.

The Driver is Microsoft from 2006 as shown in the prior thread.

Losing hope!

But thanks again

RESOLVED!

Issue was the Cable. But…

Using the old cable it works fine on all the Windows 7 or XP devices, PC’s and Laptops I’ve tried. But not on Windows 10.

Swapped for the newer cable of my ’ mypassport ultra’ and it works fine.

Go figure!!! Thanks for all the help anyway.