My Passport Model# WDBACX0010BBK-00 not recognized on factory usb 3.0 but available on usb 2.0

Just got a lenovo ideapad u300s for Christmas and can’t get my 1 T my passport to be read in the usb 3.0 slot. It is a usb 3.0 compatible version, and is recognized in the usb 2.o slot but not in the 3.0. When connected to the 3.0 it does not show up in the device manager or the disk manager. When connected to the usb 2.0 the drivers are all up to date, I also went to the lenovo website to verify the latest driver for the usb 3.0 port.  

I called the tech support and they ran me through there tests and deemed there was a problem with the usb3.0 laptop port so I sent it in to be fixed

Just got it back and still the same problem. The passport works in the usb 2 slot but not the usb 3 slot. I have a letter from lenovo saying they actually tried a 3.0 device 

Has anyone else had this problem? There is no setting in the bios to enable usb 3.0. And I seen some one post  to use a USB 3.0 A Male to Micro USB 3 Y cable for Mobile HDD because it needs the power from a usb2.0 to run the data connection in the usb 3.0 with only 1 usb 2.0 and 1 usb 3.0 I find the idea of needing both to operate one device a little ridiculous.

Please let me know of anything else I may have missed or other solutions to the problem at hand.


Well, if the drive is working on the USB 2.0 means that is good and working.

You might need to update the USB 3.0 on that computer or test the ports with a different device or passport to make sure that they are working properly.

I’ve updated the driver for the usb 3.0 still not working I will head to the store and pick up a flash drive or something the hard drive is the only usb 3.0 item I currently own. I will let you know what i find then