My Passport is not working with vista 64 and Win7 64


#1

Hi every body

My WD Passport (160GB) is working with vista 64 and Win7 64, when I connect it the white led starts blinking and (Pending to install) pops on, after a while a pop window instructs to contact the manufacturer for the driver, because no driver was found, on the other hand I have no problems at all running it with Win XP S3 32 bit, How can I solve this issue please? Help if you can.

Thanks


#2

Dear friend,

I have the same issue, did you find any solution?

Thanx a lot.


#3

Hi,

Unfortunately I did not, I tried every possible way I know but I failed, I even tried to contact WD on line, and at the end the unit died. It is still covered by the warranty, but the dealer here insisted to present him the original invoice which I lost. Though I have registered the unit on line the time I bought it.  I will never buy from WD again, and I have advised my friends at work to do so.


#4

Have you tried contacting WD’s Technical Support about this?

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en


#5

Yes I did, they responded in no time but with no solution. All the things they suggested were a (routine work). The unit was working 100% with WIN XP 32 bit, when booting from Vista 64 and WIN 7 64, it does not work. And this was the problem not what the WD’s Technical Support tried to convince me. So the problem is not the USB connector or any thing except the unit it self, or it maybe a compatibility issue. Any way I lost the WD Passport and the most important 90 GB of data.

My regards


#6

Sorry to hear that.  Yeah, there are compatibility issues between 32 bit and 64 bit.  But that’s a bridge that has to be crossed sooner or later, anyway.


#7

thepoet,

If the WD My passport was not recognize by the Vista and Win7 64bit Oses or

If you were referred to WD SES driver is needed? When the Vista/Win7 64 bit were asking.

You can find it on the WD Smartware virtual CD on the WD My Passport drive itself.

Under Extras folder, WD SES Device Driver.

It supports both 32 and 64 bit OSes.

If not what you were looking for, please ignore my suggestion.


#8

Thanks for the advice.

I tried what you suggested but the same result, and that was a month ago, initially I am reading reviews to find the best and buy it because the WD passport is dead. I need to make a ceremony and bury it :slight_smile:


#9

Hi,

I had the same problem with my WD passport on Win7 64. The solution I found is USB port mode setting in BIOS, but in my case it started to work only after BIOS upgrade to the latest version (dated by march 2010). On my notebook I have it named “USB legacy support”, so for me it works only in DISABLED state. But still I have one bug: if WD is connected to notebook before power-on WD willnot be detected it will be pointed as an UNKNOWN device, so work only at hot connection after OS startup.


#10

For a desktop at least, try plugging it into the back of your machine using the short cable, i.e. what came with the drive.  Plugging it into a port on the front of your computer is not the same thing as plugging it directly into the motherboard.  I was getting “failed installation” messages until I tried that.  Win7 64bit.