My Passport is not detected in my computer

3 days ago my passport 500gb is not recognized by my computer. but it is recognized by Smartware but it shows “No writable WD Smartware partition found”  Device manager recognized it and it shows “This device is working properly.”

Tried using USB device viewer and it shows

—===>Device Information<===—English product name: “My Passport 0730”
ConnectionStatus:                  Current Config Value:              0x01  -> Device Bus Speed: HighDevice Address:                    0x03Open Pipes:                           2
          ===>Endpoint Descriptor<===bLength:                           0x07bDescriptorType:                   0x05bEndpointAddress:                  0x84  -> Direction: IN - EndpointID: 4bmAttributes:                      0x02  -> Bulk Transfer TypewMaxPacketSize:                  0x0200 = 0x200 max bytesbInterval:                         0x00
          ===>Endpoint Descriptor<===bLength:                           0x07bDescriptorType:                   0x05bEndpointAddress:                  0x03  -> Direction: OUT - EndpointID: 3bmAttributes:                      0x02  -> Bulk Transfer TypewMaxPacketSize:                  0x0200 = 0x200 max bytesbInterval:                         0x00
          ===>Device Descriptor<===bLength:                           0x12bDescriptorType:                   0x01bcdUSB:                          0x0210bDeviceClass:                      0x00  -> This is an Interface Class Defined DevicebDeviceSubClass:                   0x00bDeviceProtocol:                   0x00bMaxPacketSize0:                   0x40 = (64) BytesidVendor:                        0x1058 = Western Digital Technologies, Inc.idProduct:                       0x0730bcdDevice:                       0x1012iManufacturer:                     0x01     English (United States)  "Western Digital"iProduct:                          0x02     English (United States)  "My Passport 0730"iSerialNumber:                     0x03     English (United States)  "575839314142304539313538"bNumConfigurations:                0x01
          ===>Configuration Descriptor<===bLength:                           0x09bDescriptorType:                   0x02wTotalLength:                    0x0020  -> ValidatedbNumInterfaces:                    0x01bConfigurationValue:               0x01iConfiguration:                    0x00bmAttributes:                      0x80  -> Bus PoweredMaxPower:                          0xFA = 500 mA
          ===>Interface Descriptor<===bLength:                           0x09bDescriptorType:                   0x04bInterfaceNumber:                  0x00bAlternateSetting:                 0x00bNumEndpoints:                     0x02bInterfaceClass:                   0x08  -> This is a Mass Storage USB Device Interface ClassbInterfaceSubClass:                0x06bInterfaceProtocol:                0x50iInterface:                        0x00
          ===>Endpoint Descriptor<===bLength:                           0x07bDescriptorType:                   0x05bEndpointAddress:                  0x84  -> Direction: IN - EndpointID: 4bmAttributes:                      0x02  -> Bulk Transfer TypewMaxPacketSize:                  0x0200 = 0x200 max bytesbInterval:                         0x00
          ===>Endpoint Descriptor<===bLength:                           0x07bDescriptorType:                   0x05bEndpointAddress:                  0x03  -> Direction: OUT - EndpointID: 3bmAttributes:                      0x02  -> Bulk Transfer TypewMaxPacketSize:                  0x0200 = 0x200 max bytesbInterval:                         0x00

The thing is, My computer does not recognize it… I need my files… my thesis and feasibility studies is inside my passport…

Please help me

Thankyou so much

please help me…

1 Like

“iSerialNumber” is the serial number of the drive inside the enclosure, so ISTM that the hard drive is being detected by the USB-SATA bridge IC.

Are you able to detect the drive with a disc diagnostic such as HD Sentinel or HDDScan?

HD Sentinel (DOS / Windows / Linux):
http://www.hdsentinel.com/

HDDScan for Windows:
http://hddscan.com/

Does the drive report its correct model number (WD50xxx) and correct capacity?

I’m having the same problem. My My Passport 0730 is showing up on the Eject Media menue, and in the Devices and Printers menue See (screen shots)

My Passport 0730.PNG

My Passport 0730 - Properties.PNG

But in Disk Drives menue it is nowhere to be found.

Computer hard disk menue.PNG

I cannot access the files. GRRRRR. what to do??? Please help.

I’ve tried switching usb cables, searching my computer for hidden drives and files (just in case) What else is there to do?

We’re all in the same boat.

Firmware + Software is up to date. Was installed correctly.

Drive shows up in “Device Manager”

Drive shows up in WDSmartWare, however it’s permanently - Drive discovering.

Inside the WDSmartWare, “No Writable WD SmartWare Partition Found”

It’s being detected by the green plug of windows showing you have something plugged into the USB-hubs.

I’ve ran scans to see if the drive is broken, corrupted or any problems. There are none, perfectly intact with the original cable which is not damaged either. 

Made sure it’s a Windows My Passport and has worked before and it stopped once I updated the firmware and software.

Does not show up in My Computer yet it’s clearly that it’s detected but just won’t register.

It does show up in “My Computer”, “Manage” and under the “Disk Management”, it’s online but not accessible.

Dear community, help us since that’s what a community is for.

Is your drive protected by a password???

no

I am having the same problems as well.  Any thoughts?

Sorry, I wasn’t sure what you meant by “scan”. If you were able to perform a surface scan via a software application, then obviously the drive isn’t password protected. However, if you used Data LifeGuard to perform an internal self test, then AFAICS this test would proceed whether or not the drive were password protected.

At this point I would use a disc editor to examine sectors 0 (MBR) and 63 (boot sector). If you can see these, then this would suggest that your drive may have a logical problem. Otherwise, if you can’t access these sectors, then I’d suspect a hardware fault.

Just some further information on the issue.

I’ve plugged the Drive into friends computers, both PC and Apple and find the same thing. (The apple however shows a bit more info on the contents of the drive than the PC) However in both cases the drive does not show up in the My Computer menu.

HI 

I have had exactly the same problem - Win7 will not recognised my Passport 1TB HD, which did not appear to be mapped to the PC!!! Go to:

‘How to partition and format a WD drive on Windows (7, Vista, XP) and Mac OSX’

 ’ on the WD knowledge base .

ALL DATA WILL BE LOST, for me this wasn’t a problem. All is now perfect.

Do you know where the # key is on the UK Mac keyboard- there isn’t one, just press alt 3.

Good luck

1 Like

Unfortunately I need the data. So that solution is not an option for me. Thank you anyway. Anybody else out there have a solution that doesn’t erase my data?

I have the same problem. I have a 500gb My Passport (supportinh both USB2 and 3). The disk worls properly, keeping showing data stored on several PCs who runs Windows XP and one who runs W7, but in both my PC (W7 32bit) and laptop (Dell N4030 with W7 64bit) appears briefly on Computer Management -Storage- Disk Management , allegedly unformatted, and every minute a “You need to format the disk” appears, but, even when I go to disk option, the system is unable to format the disk.

The unique path I didn’t try is to reformat any of my computers.

Any idea?

Still not having any luck.  I have tried on another computer, and I have tried with a different cable.  I don’t want to reformat, becaue I have a lot of information on the HD still.  Any new ideas?

2 Likes

Does WD even try to help in this forum? Or do they just ignore things here?:angry:

2 Likes

This is just a users forum not customer service.

Joe

same problem,but i can not find the disk in the disk management…sad…this product is so that a ■■■■. 1T passport essiential se 

Thanks man!

Your post was the only useful from the thousands I have read!

Greetings from BG!

I just signed up today for this forum for the same reason, its sad that WD reps aren’t on here to lend support. I replied on another thread about this problem, but here is a possible fix for some. When I plug my passport in to my PS3, it is still recognized and accessible. You can access you files from there and move them to another storage device and then re-format the passport.

This didn’t work for me because I didn’t have another storage device large enough to store 400 gigs of info. I’m pretty pisssed considering I didn’t drop my drive. My problems started after I downloaded a movie to my HD.

Hopefully we can find a fix.

Thanks to you…My passport is now detected…:wink: