My Passport has disappeared!

Please help!

I have been using mmy hard drive with no problems until I tried to transfer pictures from a card reader onto the WD at the same time. Prior to this it was as an E drive and now it is a F drive. However it says that I have nothing on the hard drive which is incorrect. It works when I plug it in to my TV with no issues.

The fan is working but for some reason there is nothing. When I plug it in it shows up in Device Manager but not Disk Management.

Any ideas. I have tried unplugging the battery on my laptop and only turning it on once the WD is plugged in. It is the same when I plug it in to other computers.

I really need the stuff on there. My fault for not having a full backup-lesson learnt!

Sounds like something is corrupt. Since it’s not showing in disk management I don’t know if recovery software will work. Search and get a Linux Live CD version burn it to disk and boot from that and see if you can access the disk. did you see if you had a System Restore point from before the problem?


Thanks Joe, I am downloading a GParted Live CD and will try that. I have been quoted $330 from a data recovery company so want to avoid that!

Will let you know how it goes!