My Passport for Mac prepares to backup, then stops

I recently installed My Passport on my MacBook Pro to replace my last one that stopped working after 20 months. So, this one is an upgrade and more capacity (2TB). It’s not as obvious what you do with this one, but so far after 10 days I have managed to get it to only do 3 back ups - I try to do them daily, but the last one that worked was 23 May. The Time Machine prepares the back up, then starts and after 360 MB it says “stopping” and does just that without completing a back up … I ran the WD diagnostic tools but nothing (I assumed there would be some form of pop up box to tell me the result, but no it just does it and - nothing … very strange to not give any feedback. Can anyone help? It obviously wants to back up as it prepares for it but I can’t understand why it just stops.
Hope someone can help of it’s going back to Amazon as I need to have a back up that works.
Thanks

Hi Northbank,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.