My Passport for Mac - Not showing up!

Hi all,

New to this community.

I recently (yesterday) bought a new My Passport fo Mac 1tb.

I plugged it in last night and it worked great, backing up my data via Time Machine.

Unplugged it, and now when I plug it in nothing happens.  My MBP won’t recognize it.

Any ideas as to what happened?

Thanks in advance!

Hello, did you safely eject it before disconnecting the USB cable? Also avoid USB extension cables or USB hubs. Also open the disk utility to see if it’s recognized there.

Help! This happned to us too. It has been working for over a year, and suddently our Mac won’t recognize it. Tried turning it off and on, unplugging, changing USB ports etc. Disk Utility does not recognize it either. 

Any help???


Try using another USB cable, or connecting the external hard drive to another Mac.

I am having the same problem with a Mac Book Pro 13 retinna display. USB3 port on left side will not mount the drive. USB on the right works. Drives are ejected properly. I have an open support request with Apple…something odd is happening. ther devices appear to work on left side USB3 port.

Try to directly connect the laptop’s power adapter to a wall outlet then try connecting the drive again.