My Passport for Mac & Mountain Lion issue

I have an encrypted My Passport for Mac so I need a password to log in. After I downloaded Mountain Lion a few weeks ago, I was able to successfully log in and back up my system. 

Today I connected My Passport and the log in box appeared as usual. I put in my password and went to log in then it froze. The ‘Show Hint,’ ‘Cancel,’ and ‘Unlock’ buttons are all grey and disabled. It will not release back to normal until after I disconnect My Passport from my Mac.

Is this a software issue that needs an update? If so, where do I get the update at?

If its not, does anyone have any idea what is going on?

Thank you

Test the unit on a different computer to see if the unit is recognize.

I just tried it on an iMac running Lion and the device is not being recognized. It is the issue I’m having on my MacBook Pro running Mountain Lion. 

Is there a way to fix this? I’ve had the device only about three months and only back up my hard drive three or four times a month so it is not constantly abused.

I have had the same issue with My Passport since upgrading to Mountain Lion.

I found this support issue on this site: 

However when I went to upgrade the firmware as suggested by this ticket, WD’s firmware upgrade crashed (see crash notes below). There’s nothing wrong with the volume - both DiskUtility and WD’s own SmartWare disk verifier gave the volume a clean bill of health. (And BTW, the firmware upgrade was unsigned, so I had to lower my security settings just to launch the firmware.)

Crash Notes when running WDFirmwareUpdater on Macbook Air 2011 running Mountain Lion:

Process:         WDFirmwareUpdater [5933]

Path:            /Users/USER/Downloads/

Identifier:      com.yourcompany.WDFirmwareUpdater

Version: (

Code Type:       X86 (Native)

Parent Process:  launchd [181]

User ID:         501

Date/Time:       2012-08-15 14:36:32.040 -0400

OS Version:      Mac OS X 10.8 (12A269)

Report Version:  10

Interval Since Last Report:          65265 sec

Crashes Since Last Report:           7

Per-App Interval Since Last Report:  113 sec

Per-App Crashes Since Last Report:   3

Anonymous UUID:                      E2FD3614-28DB-4F3F-A985-69F9FC0ACDC4

Crashed Thread:  11


Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:

*** Terminating app due to uncaught exception ‘NSInvalidReceivePortException’, reason: ‘connection went invalid while waiting for a reply’

Application Specific Backtrace 1:

0   CoreFoundation                      0x92ab07ab __raiseError + 219

1   libobjc.A.dylib                     0x98033602 objc_exception_throw + 230

2   CoreFoundation                      0x92a1023b +[NSException raise:format:] + 139

3   Foundation                          0x935c419f -[NSConnection sendInvocation:internal:] + 2310

4   Foundation                          0x935c3710 -[NSDistantObject forwardInvocation:] + 386

5   CoreFoundation                      0x929fcc50 ___forwarding___ + 896

6   CoreFoundation                      0x929fc862 _CF_forwarding_prep_0 + 50

7   WDFirmwareUpdater                   0x00007b14 -[WDFirmwareUpdate runDevicePlugin] + 204

8   Foundation                          0x935ac318 -[NSThread main] + 45

9   Foundation                          0x935ac29b __NSThread__main__ + 1396

10  libsystem_c.dylib                   0x92843557 _pthread_start + 344

11  libsystem_c.dylib                   0x9282dcee thread_start + 34

Tech support told me to connect My Passport drive to a Mac that is NOT running Mountain Lion, disable the password, then reconnect to the Mac running Mountain Lion, en re-enable password. The problem is, when I connect it to a Mac running Snow Leopard, I get a Apple dialog box saying that this drive was formatted on a more recent version of the Mac Operating system and is not readable.  Double jeopardy!

I’ve tried connecting it to an iMac running Lion and I am still having the password login box freeze everytime I try to put in my password.

Any developments on why it is doing this?