My Passport for Mac, frimware update problem

It shouldn’t matter.  Once the update was done, it was working fine.  And with the new update coming out, if you decide to update, there shouldn’t be any conflicts. 

i have just had the same problem. updated firmware and drive no longer appeared on my macbook the day after purchasing the hard drive. how long until the update will be available? i really need to  get it going again as sson as possible. western digital really should never let this have happened. substandard ! appalling !!!

Just received the replacement drive. Even though WD made a mistake the replacement did get here darn quick. Thank you.

I think WD should have paid for the shipping though as it was clearly WD’s mistake with their firmware upgrade. Everything is working fine again though and I am backing up as I write.

Question to WD!!!

I am going to be leery about upgrading again when you send me a notice. How can we be confident when getting future notices fom you?

I am having the same problem…updated firmware and now drive not recognized by my mac.  Anyone know when a fix will be available?  I spoent an hour with tech support on the phone and they told me the drive was corrupted.  Doesn’t pass the common sense test to me.

1 Like

thanarath wrote:

Here is something you can try:

Try update the firmware on the PC windows machine.

Many people have tried this and it work. 



This works! I had the same issue stated above. I plugged it in to Windows dl the passport firmwae updater for PC. Ran the Firmware updater, noticed the WD smartware VCD came back up after the power cycle. Ejected the device from my Windows machine and plugged it into my Mac, everything was there. All my files and all of my partitions. The device was also updated to the latest firmware so I was able to disable the VCD and the auto mount of VCD. Thanks for the advice thanarath!

I just bricked my passport with the firmware upgrade.  When is this fix going to be available?  I just tried to install fw 2.003.  The device is not recognized on a windows machine, either.

It sometimes works. But not always!

My MacBook Pro wouldn’t recognize the drive after the failed firmware upgrade so I tried to use a PC to upgrade the drive’s firmware and it wasn’t recognized on the PC either. I had to send it back to WD. Since I got it back it has been fine but I am now a little leery about doing any future upgrades. (But they wouldn’t do this to us twice, would they? Surely this will have them raising the bar for quality control.)

Here is the link to the WD software and Firmware update page.

I am having the same problem…???.updated firmware and now drive not recognized by my mac. Anyone know when a fix will be available? I spoent an hour with tech support on the phone and they told me the drive was corrupted. Doesn’t pass the common sense test to me.

1 Like

This problem is still active.  Luckily I had only tried to update the fireware on 1 of 2 of my SE drives that I had own, however bricked my first HD and sent it in through WD warrenty program, cost roughly $5 shipping though their site.  ■■■■■ that I had to pay to ship a drive that bricked due to their firmware update app, but I could ■■■■ that up, especially since they have the advance program which they ship out a HD to you asap and give you 30 days to ship them the defective drive.  Requested RMA on Thursday, May 20, WD shipped drive on Saturday, May 22nd and got drive on Tuesday, May 25.  Not super fast shipping but decent.

So as I am writing this review/spew, I am currenlty trying to update the firmware of the drive just received from WD as my replacement to my first bricked HD.  Brand new out of the box I hooked it up to my computer and ran the firmware update, assuming that I had done something wrong with the first hd, maybe bumping the usb cord and accidentally disconnecting it and causing the hd to brick.  As of 2 hours in, Im still sitting at around 80% progress, which only took like 3 minutes to acheive.  I called customer support and there resolution was either to wait and hope it completes successfully or to restart my computer.  Restarting is gaurenteed brick HD, as the CS agreed.  Waiting probably will not help but I decided that another hour isnt bad with the options on the table.  I’m assuming this HD is bricked and will have to send this one in as well.  The only good news here is that the CS was decent.  Though his resolution wasn’t great, Im assuming that he got that from some knowledge center, he was helpful and polite.  I mentioned that I if I was to send this drive in to WD, I would want WD to pay for shipping as this was a result of their program, in which he agreed.  Received a case number to use when I call back, after giving up on the firmware update.

I hope my soon to be 2 bricked WD Passport SE for Mac 1TB drives story helps others, it could have been 3 bricked drives.  DO NOT UPGRADE FIRMWARE.

UPDATE:  2nd HD bricked.  Requested RMA w/free shipping.  FYI:  For my drives the firmware update stalled and never completed.

Here are some tips on how to prevent further bricked the Hard disk drive on the firmware updating.

  1. If you have WD My Passport/My Book Essential or Elite (black or dark case)=Choose only the firmware in this


  1. If you have WD My Passport Studio/My Book Studio (Silver case)=Choose only the firmware in this


Do not cross the firmware update category or your drive will be bricked permanently.

If after updating the firmware your drive is not recognize by System Finder and Disk Utility.

Your drive partition and data are still there, It is just firmware did not get update.

Try update the firmware again from another Mac machine.

Make sure only the firmware updating program is running at this time.

After update is finish, be sure to restart both the computer and the Hard disk drive before new change to take effect.

If after that the problem is still there.

Move to a windows PC machine, many people are getting them to work successfully. 

I had some problem 3 days ago trying… Tell I update the firmware FROM  WINDOWS  PC machine every thing back to normal and my 500GB OF FILE  Still there

Thanks  :smileyvery-happy:

One more here! Did the upgrade last week and now the device is bricked.

Do we know yet if there is going to be some fix to this? 

I had the same problem with WD passport essential SE 1tb.I update the firmware and after i plugged it back to my laptop, the drive is not recognized. WD tech-support told me to try on a desktop, or buying a power boost cable, or send it for replacement if all doens’t work. I wonder if they told your the same thing?

I have not tried on desktop since i couldn’t find any friend who uses a desktop computer. But I really wonder if it is just a shortage of power problem. Have you tried using a power boost cable? I don’t want to spend another dollar yet the problem still not fixed.

Thank you.


Yes i also had this problem but all you need to do is do a Hard drive update via Windows and it sorts it out and all your data is saved which i was thankful for or it would have been 1.5gb of data lost Hope this helps all.

1 Like

This happened to me too and I received the same response from WD that everyone else did. Sorry our firmware update bricked your drive. Send it to us and we might send you a new one. This is the second WD Drive that died on me. I’ve lost 250GB music and countless photos. You can rest assured I’ll never purchase another WD product again.

Even if there is a fix coming how can I install it on the drive if my computer doesn’t see the drive?

Same too here, i just updated yesterday and now my hard drive wont work, i also try to my  windows pc, but unfortunately the hard drive wont show up, i was hoping it will be fixed. so frustrating!

On my side the update does not even get to the point where it bricks my drive. It crashes as soon as I launch it. Wonderful. It’s just out of the box, the VCD does not launch and so forth. Will leave it to the original firmware version I guess. 


I am happy to say this process has also unbricked my drive. Who would have thought. Great tip from several of you.

Now why have WD not (a) provided the ‘fix’ which was stated earlier? OR

(b) stated that this process works?

What a joke - far from happy with you guys. You need to be far more professional than this.

So just to reiterate - connect the drive to a PC, do a firmware update and you are all set.

Thanks again …

The PC fix is unfortunately the solution. *feels dirty!* 

I asked my fiancé to run the updates on his PC and it worked. Furthermore, it hid the VCD and made my disk a “drag-and-drop” disk. That’s is exactly what I needed.