"My Passport For Mac" does not recognize the correct password, and does not show up in Finder window

I purchased a " 1TB My Passport For Mac" External hard drive a while ago, and it used to work fine. Encrypted the drive and saved the password. Plugged it in to my MacBook pro earlier to backup my computer, entered the password, and everything worked fine for about 2 minutes. The USB connection got nudged ever so slightly, just enough for the drive the drive to “eject”. Nothing crazy at all…

Plugged it back in, and nothing happened. It did not get recognized. Restarted my computer, and plugged it back in. Dialog window popped up that asked for the password to unlock. Entered the CORRECT password. It waited for about 5 seconds before shaking to indicate the password was wrong. I attempted the same process several times and never worked. (Restarting my computer, plugging in the drive, entering the CORRECT password). I even attempted entering an intentionally incorrect password after the first attempt of entering the correct password. That caused the password dialog to disappear, but nothing else happens.

In disk utility, when plugging in the drive, it shows up under “External” as “My Passport For Mac”, however it is greyed out. Running First Aid does absolutely nothing, even though it indicates that it passed. DU indicates that the drive is not mounted. Capacity is 999.83 GB. Available shows “Zero KB” even though I probably have only about 1 gb of data on it. Used says “–”

Nothing on the internet has helped me solve this issue. I’ve seen other similar issues with the same product and everyone’s solution is to just erase the drive and start over, tough luck. Should’ve kept 5 other backups in case apparently, right? Is this how easy it is for this terrible product to become corrupt and useless? How the hell is that even possible? If that is the case then it seems as though I’m wasting my money buying these products. I’ll never waste my money on this again.