My passport files not responding

Hi all,

My 320G passport  files not responding due to unknown reason.My computer uses win 7 and i can see the passport drive and files on it.But when i click on the files to open it, some reason files stops responding and all computer freezes. I checked with ESET for virus and nothing found.I checked the properties of the drive and it says 160 GB has been used which i think the files are still inside…Even tried on a different computer still the same. .Do i need to format ,or do i need any file recovery program.  i am worried  of losing my files .Please help me out…


See if you can try a different USB cable. If you can’t find one Call WD and they’ll probably send you a new one. 


Thanks Joe,

Tried with a good cable from one of my friends passport.Still have the same issue.Also installed the drive to a different computer.Istallation took very long but after i tried to open the drive , not responding. Although it  detects drive , properties shows it has my stored data as 160 GB, Dnt know what to do …

Update- did a diagnostics from drive settings and heres the result

Quick smart status  - failed

Quick drive test - failed


Any ideas …i am going to format the drive…is that going to wipe of my memory .Can i retrieve my files back after that ? please show mw some light on this issue…


62 views and no reply …friends , please give me a solution…i tried free data recovery software ( stellar )  but still no luck .i am trying evrything on this drive to get the data back and by the time i get a reply from forum may be the drive will rest in peace…thanks