My Passport Fail

Hello I have 1TB My Passport. Recently its speed goes down and it’s take long time to appear in my computer so I search I found I had bad sectors. So I connect my passport. And run HDD Regenerator software. I start to search and repair bad sectors. The software found many bad sectors and fix theme but suddenly in the middle of fixing it disconnect. So I unplug the device and plug in again but hard didn’t appear in my computer however it show in ‘Device and Printers’ and ‘Safety remove’ after several minutes. And in HDD Regenerator said: master boot record failed. I run disk management it shows my drive letter but no size 0 MB. It says: Disk 2 Unknown no initialized and It cannot be initialized. I ran AOMEI Partition Assistant and click rebuild MBR and It did but didn’t help. Please help me it’s emergency.

I have the same problem with the same device.  Mine is Disk 1 unkown no initialized.  it also beep for a few seconds. 


I believe both of you have failed drives. You can try running a diagnostic using WD DLG to make sure that I am correct. If the drive fails any of the tests then it means the drive is defective and needs to be replaced.

I ran Data Lifeguard Diagnostic. and start the quick test and extended test and it pass!

but in smart status it say ‘Not available’ and capasity is 0 MB. How can it be fail without any strike?