My Passport external hdd 1tb WDBBEP0010BBK-01 - Not recognised

Hi I’ve been using my hard disk for the past six months.

But suddenly it stopped working.

When i connected it to my laptop the light blinks in the drive and the got detected but i dont see the memory usage. it just shows the a drive symbol. I attached the screen shot below Drive is my hard disk

in windows 7

Also i tried connecting it to a ubuntu system it shows: 

Error mounting - mount exited with exit code 13: ntfs_attr_pread_i:ntfs_pread 

failed: I/O error

I also tried to do a chkdsk in windows but it gets hanged in the process… Please help with the issue

in Ubuntu

Thanks in advance

–Selvaraja M

Try testing the drive with our Data Lifeguard Diagnostics software or Windows chkdsk.

How to test a drive for problems using Data Lifeguard Diagnostics for Windows

http://wdc.custhelp.com/app/answers/detail/a_id/940

Hi John

Thanks for your reply.

I tried your suggestion. When I do a chkdsk the system gets hanged, and its not progressing.

I also tried Data Lifeguard Diagnostics software which couldn’t detect my drive, attaching the screen shot for the same

in the above screen shot k is my drive, which is not getting detected.

Please help on this.

awaiting your reply

Selvaraja M