My passport essentiel not recognize

I bought a western digital my passport essentiel of 500G about 4 month ago. It’s been working well when I bought it and used it a lot of time. Now, when I connect my hard drive, it is recognize in devices managers, but I can’t see it in my computers. I can also see it in the WD software but it’s written “No writable WD SmartWare partition found” and I can’t do anything in the software. Also, when I go in disk management, I can see the hard drive but he is not initialize, but I can’t initialize it because of an I/O device error. Ive tried to uninstall the drivers or update it but it doesnt change anything. Finally I tried to format with the WD thing you download from the site but it doesnt work.

Can anyone help me?

Sorry for my english :slight_smile:


That thing just happen to me a long time ago… Maybe you need to replace your external hard drive. If your external drive is under warranty you should visit this website…



Try running the WD DLG and see what that shows. The drive may be bad if it’s still in warranty contact WD for replacement.